Support » Plugin: Active Directory Integration » [SOLVED] Checking domain controller ports: [ERROR] FAILED

  • On a fresh Centos 7 installation with LAMP following these instructions:-
    https://www.howtoforge.com/apache_php_mysql_on_centos_7_lamp
    https://www.howtoforge.com/centos_wordpress_install
    then add the ADI plugin, configure and….

    Maybe I missed it somewhere int he installation notes but to save anybody else the time trying to figure it out, here’s how I fixed a problem where my ADI would not work, even with the firewall switched off. I could use ldapsearch at the command line OK but nothing from ADI in the browser.

    a comment on this page sorted me out:-

    /usr/sbin/setsebool httpd_can_network_connect=1

    I didn’t think I was using SELinux but apparently so.
    cooking on gas now 🙂

    Previous error message with additional error codes reporting:-

    openLDAP installed
    [INFO] method authenticate() called
    [INFO] ------------------------------------------
    PHP version: 5.4.16
    WP version: 4.5.3
    ADI version: 1.1.8
    OS Info : Linux wp.mydomain.co.uk 3.10.0-327.28.2.el7.x86_64 #1 SMP Wed Aug 3 11:11:39 UTC 2016 x86_64
    Web Server : apache2handler
    adLDAP ver.: 3.3.2 EXTENDED (201302271401)
    ------------------------------------------
    [INFO] LDAP paging: enabled
    [NOTICE] username: aUser
    [NOTICE] password: **not shown**
    [INFO] Options for adLDAP connection:
    - account_suffix: @mydomain.myforest
    - base_dn: OU=Users,OU=people,DC=mydomain,DC=myforest
    - domain_controllers: 192.168.5.5;192.168.5.6
    - ad_port: 389
    - use_tls: 0
    - network timeout: 5
    [INFO] Checking domain controller ports:
    [ERROR] - 192.168.5.5:389 - FAILED
    $errCode = 13
    $errStr = Permission denied
    [ERROR] - 192.168.5.6:389 - FAILED
    $errCode = 13
    $errStr = Permission denied
    [NOTICE] adLDAP object created.
    [INFO] max_login_attempts: 0
    [NOTICE] trying account suffix "@mydomain.myforest"
    [ERROR] Authentication failed
    [WARN] storing failed login for user "aUser"
    
    Logon failed

    https://wordpress.org/plugins/active-directory-integration/

Viewing 1 replies (of 1 total)
  • I love you so much right now. Same exact situation, I moved the wordpress site over from IIS, so I knew the LDAP config was spot on.

    /usr/sbin/setsebool httpd_can_network_connect=1

    This magic setting resolved my connection issue. Thank you @bigste

Viewing 1 replies (of 1 total)
  • The topic ‘[SOLVED] Checking domain controller ports: [ERROR] FAILED’ is closed to new replies.