WordPress.org

Support

Support » How-To and Troubleshooting » Solutions: Login problems

Solutions: Login problems

  • I’ve collected it all again so that it all stays together – if I have missed anything, let me know and I will add it here.
    ==================
    Another summary of what’s around the forums.
    Try to login after each step.
    #1. Clear your cookies
    Cookies are in your computer.
    In windows they are in
    C: / docs and setting / username / Cookies folder.
    #2. Clear the temp cache on your computer
    #3.Edit wp-login.php
    Go to the “case ‘retrievepassword’:” section.
    Just under the comment (In 1.2mingus, the line in question is number 204):
    // redefining user_login ensures we return the right case in the email
    Replace:
    $user_login = $user_data['user_login'];
    with:
    $user_login = $user_data->user_login;
    #4. Your blog host should provide you with phpMyadmin access to your databases for you to do this.
    Open phpMyadmin, and click on the users table in the left menu (it could be wp_users, or yourprefix_users)
    Click “Browse”
    Click on the edit button next to the admin user.
    Delete whatever is in the password field.
    Now go to http://bfl.rctek.com/tools/?tool=hasher
    enter your desired password, and copy the hash that it generates
    Paste the hash in the password field for admin
    Save the info in the database.
    Login to WordPress using “admin” and the password you used to create the hash.
    A guide to doing this is here: http://www.mfr.f2s.com/phpmyadmin/
    #5. Secure HTTPS ?
    Change the following line in wp-includes/vars.php from:
    define('COOKIEPATH', preg_replace('|http://[^/]+|i', '', get_settings('home') . '/' ) );
    To:
    define('COOKIEPATH', preg_replace('|https?://[^/]+|i', '', get_settings('home') . '/' ) );
    Be sure also to change the url in Options to https://
    (Credit for this solution to mcnicold)
    #6. Head over to http://www.sexygirlgeek.com/share/wp-login.phps
    Copy the all the text from <?php to ?>
    Save it as ‘wp-login.php’
    Upload it to your wordpress directory
    (If you get an error about ‘headers already sent’ after doing this, go here: http://faq.wordpress.net/view.php?p=7
    (Credit for this solution to sexygirlgeek)
    ==================
    If these steps fail, please say this when posting and give details of your server setup if you know it, mysql and php versions, OS and browser, WordPress version.

Viewing 15 replies - 1 through 15 (of 24 total)
  • Cool Podz. Thanks 🙂

    Login fails with a test.
    Have you tried every step above ?

    Yup, every step.
    I just installed 23/07 nightly but that didn’t work either. I’m going to back to the original 1.2 mingus.

    im working through each of the steps described above, but it doesnt seem to
    do the job( for me anyway).

    podz, why don’t you put this in the wiki ?
    For example here : http://wiki.wordpress.org/GeneralFaqs

    Okay, I’ve been having the precise same problem, and podz’ advice is spot on; works now. podz, thanks.
    Clearing cache didn’t work; I think it was that one line edit on wp-login.php that did it though.
    Again, thanks.

    I had a login problem after moving my site. Here’s a new possibility, although I don’t know what causes it.
    In the wp_options table there is an option_name “home”. For whatever reason this option did not get updated when I changed my site_url. I went into phpmyadmin and changed it to the correct entry (same as site_url) and everything is hunky-dory again.
    ~leeman

    Thank you sunshine – I know you’ve mentioned this before.
    When I next add to those pages, I will include your suggestion 🙂

    Okay, I just wasn’t sure if you got it or not — I thought I’d commented, but then I couldn’t find it later. Its so sad when the mind goes…. 😉

    I’ve been busy, and somewhat distracted 🙂

    Created a login and password for a new user. He’s on a Mac and can’t get in. Says he’s aware of the case sensitvity. I can log on with his userid and p/w on my machine though.
    Anyone have this problem?

    Ok, I’ve had the exact same problem while trying to install 1.2 Mingus today for two separate sites. I’ve gone through the directions above, but when I get to Step #4 (after hashing the pwd), I still can’t log in.
    On top if it, the login page is being oddly redirected. Instead of going to:
    http://www.somedomain.com/wp-login.php
    It’s going to:
    http://www.somedomain.com/wp-login.php?redirect_to=%2Fwp-admin%2F
    I’ve tried registering as another user but the same thing still happens: back to the login page, without access. (Reporting a lost password doesn’t work, either.)
    I’ve even deleted the .htaccess file, to no avail.
    Any ideas???

    2 days ago my site reverted back to an older MT site I was running, no notice from my ISP but I think som files got restored. I pushed a backup I have up and the site works, but now I can’t login. I have tried the replacing the Password option and the changing the line in wp-login and neither work. Are there any file rights that could be goobered becaus eof the restore that would affect my ability to log in?

    None of the steps are working for me either.
    Symptoms of the problem:
    1- I upgraded today from b2 .6.2.x
    2- I followed the instructions from the wiki
    documentation

    While I had some problems with the addeumum it did eventually work (When I ran the import I believe I got an sql err. I will try and reinstall tonight and post it if it occurs again).
    3- Moved all files into root directory of my webpage (Since i didn’t run install.php or update.php I didn’t have options on how to set files up)
    4- Login to admin failed, tried reseting pwd through e-mail reminders, no luck. Tried all steps. (minus https, since I’m not using https).
    The server is a linux box, running ‘mysql Ver 11.18 Distrib 3.23.58, for redhat-linux-gnu (i386)’ and php 4.38 with apache 2.0
    I’m going to restore my db now and start over again. Let you know if anything changes.

    re-imported blog, only sketchy message this time:

    Found table ‘b2links’, don’t need to create it…
    … may need to update it though. Looking for column link_updated…
    Looking for column link_rel…

    no luck with the admin password, nor when I reset it using phpadmin.

    trying method above Addendum which calls for the install.php to be run. No luck. Tables that I havc after all said is done are as follows:
    b2categories
    b2comments
    b2linkcategories
    b2links
    b2optiongroup_options
    b2optiongroups
    b2options
    b2optiontypes
    b2optionvalues
    b2post2cat
    b2postmeta
    b2posts
    b2settings
    b2users
    ljposts
    ljusers

    All are of type MyISAM.

Viewing 15 replies - 1 through 15 (of 24 total)
  • The topic ‘Solutions: Login problems’ is closed to new replies.
Skip to toolbar