Support » Fixing WordPress » Solution to fix previous_post funtion in WP1.5.1

  • I notice several people emailing me about how to use previous_post and next_post tag on both main page and single post page and that such functionality disappeared when they upgrade to WP 1.5.1.

    So here it is, how to make it works without ever modifying a single code on WP files.

    http://www.blueblurry.com/navigation-fix/

    Also, help me comment on my blog design and vote for me at photoblogs.org if you like it. Thanks

Viewing 13 replies - 1 through 13 (of 13 total)
  • Just for clarification for others: does WP 1.5.1.1 (the current version!) need this fix, too?

    Moderator James Huff

    (@macmanx)

    does WP 1.5.1.1 (the current version!) need this fix, too?

    No, this has been fixed in WP v1.5.1.1. See: http://mosquito.wordpress.org/changelog_page.php

    So the more appropriate solution is found here (since it fixes a lot more than this issue):

    http://wordpress.org/download/

    To clarify, WP 1.5.1.1 DOES NOT fix the problem because it is not a problem at the beginning. The previous_post / next_post were never meant to work ever since 1.5 but there seemed to be a loophole so it did work.

    Since they fixed it in 1.5.1, it will not work anymore; hence, I post this solution.

    Then this doesn’t fix anything, since next/previous_post work exactly as intended. What you’re providing is a hack to change their behavior–which is fine. But if we’re going to clarify, then let’s do so.

    exactly as intended??
    then I should go back to 1.5

    Maybe the developers “intention” is not exactly the same as yours… 🙂

    Moderator James Huff

    (@macmanx)

    To clarify, WP 1.5.1.1 DOES NOT fix the problem because it is not a problem at the beginning. The previous_post / next_post were never meant to work ever since 1.5 but there seemed to be a loophole so it did work.

    Since they fixed it in 1.5.1, it will not work anymore;

    That’s odd, why would the developers write a feature and then include it in the Default template if their intention was for it not to work? Where are your sources and references for this?

    For the record, the next/previous_post feature worked for me in v1.5, it worked for me in v1.5.1, and it still works for me in v1.5.1.1.

    Moderator James Huff

    (@macmanx)

    Also, if this feature was never intended to work, then why has it been resolved in revision 2602 of template-functions-links.php and included with WP v1.5.1.1?

    If you dont have a problem why bothering?

    WE HAVE A PROBLEM, LET US TRY TO SOLVE IT.

    So I guess I should have called it a hack, not a fix and this whole discussion would not have happenned. Nevertheless, I do believe that many people have the same problem as I do.

    http://wordpress.org/support/topic/33255

    Thank you so much Pat! Works like a charm!

    I have been trying to get the navigation fix at http://www.blueblurry.com/navigation-fix/, but it keeps displaying the “Server not found” error. Anyone else who could send me the fix, or direct me to somewhere from where I can obtain it?

    Thanks 🙂

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Solution to fix previous_post funtion in WP1.5.1’ is closed to new replies.