Support » Plugin: WP MyLinks » Solution If You Encounter 404 Error

  • Plugin Author walterpinem

    (@walterpinem)


    Hello all.

    First of all, thank you very much for using this plugin.
    If you encounter a 404 error after publishing your MyLinks page, please reset the permalinks by following these steps:
    Dashboard => Settings => Permalinks => click the Save Changes button without having to change anything.

    The plugin already has a function to automatically flush the permalinks upon activation and page published, but sometimes it’s still not working perfectly as intended.
    I’m still looking for the solution.

    Thanks in advance.

Viewing 3 replies - 1 through 3 (of 3 total)
  • I kept trying and trying to no avail, but found that changing my permalink settings to ‘Post name’ instead of a custom structure with the category and then the post name worked. It’s a shame though because it means that I have to update all of my posts to this structure, but it will have to do for now.

    Thanks for all the work you’re putting into this plugin – it’s really useful and I’m planning a post/video talking about it!

    I tried it but I still have a 404 error!

    Hello,
    With Woocommerce installed on WordPress, permalinks are defined this way : /%category%/%postname%/

    By setting a landing page with the name “bio”, the link displayed is http://dns.com/bio/ but this link gets me a 404.
    I found that the correct link is http://dns.com/mylink/bio/

    So if you have the same permalink setting as me, don’t forget to put the mylink keyword in the link.
    (The solution given by the author doesn’t work in my context).

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Solution If You Encounter 404 Error’ is closed to new replies.