Support » Plugin: Custom Permalinks » Solution for 404 errors with SSL requests

Viewing 4 replies - 1 through 4 (of 4 total)
  • I guess the plugin supports WP 2.6 or higher and the home_url() function only appears in 3.0 or later. So, this patch won’t work if you are pre-3.0.

    Hi Harold, could you tell me how to install the patch.

    I have tried editing the links but it gives me a garbled version of what my edit says. Will the patch help?

    Many Thanks

    Actually Harold I believe the only thing that needs to change is in the custom_permalinks_original_post_link function. That one is using get_option('home'), switching it to get_home_url() seems to work. It’s also why custom permalinked pages are working on SSL without this change, as the custom_permalinks_original_page_link function uses get_home_url() already. I guess it’s an oversight on the author’s part.

    get_home_url is then defined later so that the old versions of wordpress will use the statically defined option home from the db.

    @tradedog, you can edit the file by going to /wp-admin/plugin-editor.php?plugin=custom-permalinks/custom-permalinks.php

    Just follow my post above.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Solution for 404 errors with SSL requests’ is closed to new replies.