WordPress.org

Forums

Duplicator
[resolved] Socket support (5 posts)

  1. Marko Heijnen
    Member
    Posted 1 year ago #

    Is it possible to add socket connection support? For now I manipulated the installer.php script and abstracted the mysqli_connect function to this: https://gist.github.com/markoheijnen/c4284c361ac4031748d9.

    https://wordpress.org/plugins/duplicator/

  2. Cory Lamle
    Member
    Plugin Author

    Posted 1 year ago #

    Hey Marko,

    You can pass the port number in the hosts field if you need.

    localhost:1234

    Cheers~

  3. Marko Heijnen
    Member
    Posted 1 year ago #

    Should I now start wondering the quality of this plugin?

    A socket connection isn't a different port but something like /var/bin/mysql.sock
    With mysql you can do localhost/thepath/mysql.sock but not for mysqli. Check my code example.

  4. Cory Lamle
    Member
    Plugin Author

    Posted 1 year ago #

    Hey Marko,

    My bad, I apologize! I had a similar question posted recently about ports and just made an assumption of your question. Sometime I just blast through a series of these posts to get them answered. So many of the questions that are asked are not from other developers actually helping so I naturally assume newbie or a user who didn't read the manual on 99% of the threads...

    Yes I know what a socket connection is and I don't see what that would be an issue. It looks like you already have it completed anyways... I'll just merge it into the next release or the Dev Line.

    Again... Sorry for ignoring your valid contribution...

    Thanks~

  5. Cory Lamle
    Member
    Plugin Author

    Posted 1 year ago #

    Hey Marko,

    If you can give the developer version (0.5.3) it has these changes. The developer version can be found by following these instructions:

    -> Browse to http://wordpress.org/extend/plugins/duplicator/developers/
    -> Look for the section "Other Versions"
    -> Click on "Development Version" and download the zip plugin file
    -> Uninstall your current version and install this one
    -> Note: This is a development line version so please test in your sandbox first to make sure you have no issues...

    Let me know if this fixes the issue you were having with the old installer...

    Thanks

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Duplicator
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.