Support » Plugin: Social » Social won't broadcast to my facebook page!

  • Hey everyone,
    I have been getting this message and problem for over a month, but I have tried a few different things thinking it would change.
    My posts successfully get broadcast to my twitter account but it won’t post on my facebook page.
    I have tried deleting the plugin and starting from scratch and it still persisted. I tried deactivating my linked facebook and twitter accounts, same thing.
    I updated the plugin a couple of times thinking that would change, but still nothing happened so here I am again here today.
    Does anyone else have this problem?
    Here is a screen shot of the message i get for every post:

    “Social failed to broadcast the blog post “TEST” to one or more of your social accounts.
    Facebook: Asha Dahya (an unexpected error occurred. Please retry your request later.)
    Possible Fixes: Social was not successful in broadcasting this post (perhaps the service is down?) please try broadcasting again. If you receive this message repeatedly, you can try the support forums.”

    So here I am asking for help! I don’t know why it says there is a problem with my facebook since I have not changed my password. Also, when i go back into the post and manual broadcast it, that is the only way it works, but that is such a pain in the butt since I use the plugin to do it automatically so I don’t to be in front of my computer!

    Does anyone have any insight that could help me?

Viewing 7 replies - 1 through 7 (of 7 total)
  • I’m having a similar issue. When I try to broadcast, I get an error that says “Error validating access token: The session has been invalidated because the user has changed the password.” but even if I remove and re-apply the setting for my Facebook account, with the latest password, I still get this error, so I suspect that it may be inaccurate.

    Hi Dylan,

    that sucks. I wonder if there is a glitch within the plugin? Is there anyway to find out? I hope someone here can help us get this fixed. I can’t find any other plugin that is similar, or I would totally switch. I like Social, when it actually works!

    I have found a partial alternative. The Jetpack plugin for WordPress includes the ability to share posts that is very similar to this one, with the addition of a few more social networks as well. It doesn’t cover comments-integration, but I’ve been using them both together for a few days now without much trouble. I just disable Social’s sharing features for now.

    The developer says they can’t reproduce this error and until they can, there’s nothing to be done. Can anybody try this:

    1. disable all plugins except social
    2. try sharing a post to facebook
    3. does the error happen?

    if the error does not happen, it is likely caused by a conflict with another plugin. Post here with any results if you can!

    Thanks for the tips Dylan, I will take a look at my jetpack settings and see if I can broadcast from there.
    I will also do a test disabling all plugins except social and see if it is clashing with one of those. Good thinking! Will post results after I try.

    Hey Dylan, and anyone else who this problem is happening to.
    So I tried disabling all plugins except social and here’s what happened.
    When I did a test post and published it right away, it worked.
    When I did a test post and scheduled it to be published a little later, it once again failed.
    So I am thinking it happens when I schedule a post for a later time or date, as opposed to publishing it right away.
    I really wish there some plugin developers would would chime in on this because it is really frustrating!
    Another question, I am using the ‘Simple Facebook Connect’ Plugin, could this be a problem? I am having trouble deleting this darn thing to test and see if this fixes it.
    Any luck with your test?

    Ok so I deactivated and deleted the Simple Facebook Connect’ plugin and tried a couple of tests and it worked when I scheduled it to be published later as opposed to right away.

    On my site I have a few posts to be scheduled on Monday, so fingers crossed it works again after these tests!

    Will post to let everyone know if it is a success or not, I can never be too sure with tests. Stay tuned….

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Social won't broadcast to my facebook page!’ is closed to new replies.