Support » Plugin: Social » Social plugin fails to post blog comment to Facebook

  • I’m using version 2.9.2 of the Social plugin and 3.5.2 of WordPress. Every time I try to respond to a comment on my blog using my Facebook account, I get this message:
    Warning: array_shift() [function.array-shift]: The argument should be an array in /home/tkonkel/public_html/wp/wp-content/plugins/social/lib/social/service/facebook.php on line 114

    Error: Your comment could not be sent to Facebook, please go back and try again

    It also happens if I just try posting a comment on a blog entry via my Facebook account (e.g. not responding to a comment, just making one myself.) I have already tried disconnecting the Facebook account, then reconnecting it. I have also tried deactivating the plugin, then reactivating it. It didn’t make a difference. This feature used to work. It stopped working sometime between March 1, 2013 and July 1, 2013. Has anyone else seen this? Is there a fix for it? I also turned on the debug option, so I have a debug file. If the developer thinks it would be of use, I can provide it. I would just rather not post it in a public forum.
    The site is
    Thanks, Ted

Viewing 2 replies - 1 through 2 (of 2 total)
  • I am receiving the same type of error. Full error is

    Warning: array_shift() expects parameter 1 to be array, null given in (My server's location).com/html/wp-content/plugins/social/lib/social/service/facebook.php on line 114
    Warning: Cannot modify header information - headers already sent by (output started at (My server's location).com/html/wp-content/plugins/social/lib/social/service/facebook.php:114) in(My server's location).com/html/wp-includes/pluggable.php on line 876'

    Any thoughts?

    So, no help for this?
    I do have one other piece of information. If I just reply to a blog comment using my Facebook identity, the reply works. My reply only fails (as specified in my original post) when I also click the “Post to Facebook” check box.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Social plugin fails to post blog comment to Facebook’ is closed to new replies.