Support » Plugin: Yoast SEO » Social meta descriptions not working

Viewing 1 replies (of 1 total)
  • Plugin Support devnihil

    (@devnihil)

    If you are seeing unexpected behavior or appearance for one of your site’s social previews when sharing it on social media, this can be caused by the social media site caching old metadata for that page. This is why you may not immediately see the new values you set up for the page reflected in the page’s preview when you share it (image, title, description, etc).

    To resolve this, we would first recommend to try checking your page’s link using Facebook’s Sharing Debugger tool located at https://developers.facebook.com/tools/debug/sharing/. Can you please try running the Facebook Sharing Debugger on the page you are experiencing the issue on, and under ‘When and how we last scraped the URL’ clicking the ‘Scrape Again’ option and letting us know whether this resolves the issue? The ‘Scrape Again’ option will force Facebook to update it’s cache for your page’s link.

    Please note that to successfully update the cache it may require re-scraping your page several times as whether the page’s data can be read may take several requests between Facebook and the server your website is hosted on. Also, this guide includes more information on this and explains in detail how to do this: https://kb.yoast.com/kb/facebook-sharing-updated-details/

Viewing 1 replies (of 1 total)
  • The topic ‘Social meta descriptions not working’ is closed to new replies.