Support » Fixing WordPress » Social Media Links not Creating Preview

  • Resolved thomasmccaul

    (@thomasmccaul)


    hello, I know this question has been asked many times, and I have read many posts and websites but with a limited scope of html, it is difficult for me to locate the solution.

    I have run the Facebook Developer Tool and this is the output:

    “Provided og:image URL, https://tommccaul.com/wp-content/uploads/MG_2628_blended-2.jpg could not be processed as an image because it has an invalid content type.”

    on many other occasions it mentioned “the ‘og:image’ property should be explicitly provided”

    or something about Inferred Property

    here is additional info it provided on Raw Tags:

    <meta charset=”UTF-8″ />
    <meta name=”viewport” content=”width=device-width, initial-scale=1″ />
    <meta name=”description” content=”A Wandering Photographer” />
    <meta property=”og:locale” content=”en_US” />
    <meta property=”og:type” content=”website” />
    <meta property=”og:title” content=”on the road | Tom McCaul” />
    <meta property=”og:description” content=”A Wandering Photographer” />
    <meta property=”og:url” content=”https://tommccaul.com/” />
    <meta property=”og:site_name” content=”Tom McCaul” />
    <meta property=”fb:app_id” content=”368267297429960″ />
    <meta property=”og:image” content=”https://tommccaul.com/wp-content/uploads/MG_2628_blended-2.jpg” />
    <meta property=”og:image:secure_url” content=”https://tommccaul.com/wp-content/uploads/MG_2628_blended-2.jpg” />
    <meta property=”og:image:width” content=”1200″ />
    <meta property=”og:image:height” content=”800″ />
    <meta name=”twitter:card” content=”summary_large_image” />
    <meta name=”twitter:description” content=”A Wandering Photographer” />
    <meta name=”twitter:title” content=”on the road | Tom McCaul” />
    <meta name=”twitter:image” content=”https://tommccaul.com/wp-content/uploads/MG_2628_blended-2.jpg” />
    <meta name=”generator” content=”WordPress 5.2.3″ />
    <meta name=”msapplication-TileImage” content=”https://tommccaul.com/wp-content/uploads/cropped-MG_1717-1-270×270.jpg” />

    I have uninstalled every plugin, I have tried Yoast, I have tried various social media outlets with no avail

    I have tried clearing cache, setting header images, and even changing themes

    I have called my host company – Host Gator – and they see no issues on their end

    the only thing that has changed is that I upgraded to https

    I have a feeling I have to make changes to the php, which is far beyond my knowledge, so I was hoping someone could guide me

    thank you,
    Tom

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Joy

    (@joyously)

    This is not a WordPress question.
    When I click on your link to your image, I get a 403 error (forbidden).
    Try to fix the specific thing that the Facebook tool tells you. It is the one doing the preview, not your site.

    I have endlessly tried to fix the outlined issues to the best of my ability but I don’t know what I’m doing

    if I knew how to fix the thing I wouldn’t be pleading for help

    I need guidance

    Tom

    Hi Tom – I compared how your page is loading MG_2628_blended-2.jpg (the image you’re listing for og:image, which is also included in your page) with what happens in a request for just the image, and one difference is when the page requests the image, it includes in the Request Headers referer: https://tommccaul.com/. When I request just the image, there is no referrer (of course) and I get the 403 Error Forbidden message (same as Joy). If I edit the Request Headers for just the image to include referer: https://tommccaul.com/ and resend it, your server sends me the image.

    I’m not sure what’s causing your site to reject requests that don’t have a referer. I checked one of the WordPress sites I support (which is https & 5.2.3) and it has no problem with a request for an image without a referer.

    There is a post on wordpress.stackexchange.com for a similar problem from 4 years ago (403 Forbidden when accessing image in wordpress), but the post doesn’t list a solution (although I followed the links the original poster had and his site does now work).

    One thing you could try is to temporarily disable all of your plugins to see if the problem goes away. At least that might point to what’s causing your site to reject requests without a referer.

    Rich

    PS. You might want to look into an image lazy load plugin – your home page is 70 megabytes and to get the 403 error, I need to have my cache disabled, so it takes a while to reload your page.

    Rich, I greatly appreciate your response, in particular, letting me know about image lazy loaders – I installed a plugin that spent over an hour automatically resizing images. I guess it never occurred to me.

    I will update with further findings

    regards,
    Tom

    hello all, I called my web host and asked to provide guidance to correcting folder permissions for my images etc

    that was not the issue, the permissions were correct

    the gentleman discovered – I believe – that the htaccess file was missing/corrupt and he created a new one which immediately resolved the issue

    he also said that WordFence was acting a little too aggressive and suggested that I make some tweaks (didn’t advise which ones)

    thanks for the suggestions,

    Tom

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.