Support » Fixing WordPress » Social Media Causing Site Slowdown/Unable to Load

  • I attempted to link Pinterest via meta tags and using a plug-in and my website has hit massive slow-downs now. I’ve since removed the plug-in but the slow loading has stuck around and it’s near unusable on mobile. On Google Pagespeed I can see on mobile the 3 loading dots and a Pinterest save button and on desktop as the site loads a Pinterest save button appears. I am at a loss for how to fix this. Previously I was hitting 70-80 on mobile for Pagespeed and low 90’s on desktop but now it shows multiple JS errors regardless of the optimization settings I select.

    i’ve attempted to disable all plug-ins
    Attempted swapping themes, deleting the previous theme and re-installing it.
    Backing up the website, deleting it and restoring it.

    Could very well have made it worse but I went through the troubleshooting that I could find online.

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • On my side, I see that the screen is constantly loading resources from twitter, maybe you can try disable twitter feeds?

    Sure thing, I disconnected Twitter from WordPress, de-activated Yoast SEO, and deleted social media buttons. I don’t have live updated Twitter streams or feeds on the site.

    Your website is loading fine to me now after I cleared the cache.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.