WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Social login appears on wp-login page but not for comments

[Resolved] Social login appears on wp-login page but not for comments

Viewing 6 replies - 1 through 6 (of 6 total)
  • I’m facing the same issue.

    Plugin Author Miled

    @miled

    Have you tried using the shortcode or it doesn’t work either?

    Thanks for the reply.

    Shortcode seems to be working, barring some CSS issues.

    Can you just verify that I put the php code in the ideal place? Here’s the code from comments.php:

    <!-- You can start editing here. -->
    <div id="commentsbox">
    <?php if ( have_comments() ) : ?>
    	<h3 id="comments"><?php comments_number('No Responses', 'One Response', '% Responses' );?> so far.</h3>
    
    	<ol class="commentlist">
    	<?php wp_list_comments(); ?>
    	</ol>
    
    	<div class="comment-nav clearfix">
    		<div class="alignleft"><?php previous_comments_link() ?></div>
    		<div class="alignright"><?php next_comments_link() ?></div>
    	</div>
     <?php else : // this is displayed if there are no comments so far ?>
    
    	<?php if ( comments_open() ) : ?>
    		<!-- If comments are open, but there are no comments. -->
    
    	 <?php else : // comments are closed ?>
    		<!-- If comments are closed. -->
    		<p class="nocomments">Comments are closed.</p>
    
    	<?php endif; ?>
    <?php endif; ?>
    
    <?php if ( comments_open() ) : ?>
    <div id="comment-form">
    <div id="respond">
    
    <h3><?php comment_form_title( 'Leave a Reply', 'Leave a Reply to %s' ); ?></h3>
    
    	<small><?php cancel_comment_reply_link(); ?></small>
    
    <?php if ( get_option('comment_registration') && !is_user_logged_in() ) : ?>
    <p>You must be <a href="<?php echo wp_login_url( get_permalink() ); ?>">logged in</a> to post a comment.</p>
    <?php else : ?>
    
    <form action="<?php echo get_option('siteurl'); ?>/wp-comments-post.php" method="post" id="commentform">
    
    <?php if ( is_user_logged_in() ) : ?>
    
    <p>Logged in as <a href="<?php echo get_option('siteurl'); ?>/wp-admin/profile.php"><?php echo $user_identity; ?></a>. <a href="<?php echo wp_logout_url(get_permalink()); ?>" title="Log out of this account">Log out &raquo;</a></p>
    
    <?php else : ?>
    
    <?php do_action( 'wordpress_social_login' ); ?>
    
    <label for="author">Name <small><?php if ($req) echo "(required)"; ?></small></label>
    <input type="text" name="author" id="author" value="<?php echo esc_attr($comment_author); ?>" size="22" tabindex="1" <?php if ($req) echo "aria-required='true'"; ?> />
    
    <label for="email">Mail <small><?php if ($req) echo "(required)"; ?></small></label>
    <input type="text" name="email" id="email" value="<?php echo esc_attr($comment_author_email); ?>" size="22" tabindex="2" <?php if ($req) echo "aria-required='true'"; ?> />
    
    <label for="url">Website</label>
    <input type="text" name="url" id="url" value="<?php echo esc_attr($comment_author_url); ?>" size="22" tabindex="3" />
    
    <?php endif; ?>
    Plugin Author Miled

    @miled

    heck. there was no need to past that entire code..

    go to Wdiget > Widget CSS and add this
    #wp-social-login-connect-options a {float: left;padding: 2px;text-decoration: none;}
    #wp-social-login-connect-options {height: 50px;}

    If this still can’t fix it for you, then consider hiring someone.

    Sorry, I’m not a programmer and I wasn’t sure if I was placing the shortcode in the proper place in terms of the php logic.

    Thanks for the CSS.

    As it turns out, the authentication widget appears above comments if my settings say anyone can comment without registering. If I require registration, the widget does not appear.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Resolved] Social login appears on wp-login page but not for comments’ is closed to new replies.