Support » Plugin: Social Connect » Social Connect does not work at all

  • Hi,

    So i’m trying to use Social-Connect on WordPress 3.1, but I’m not getting anywhere,.

    I’ve tried installing it under social-connect, and wp_social_connect I’ve tried modifying the file so it points to /user.php rather than /registration.php but all I get is each of the links saying javascript:// (chrome/firefox) or just // (safari)

    I feel like I’m doing something stupid, but have no idea what I’m doing wrong,

    I’m also using the modularity lite theme, but that shouldn’t worry about a login button…Any help that can be offered would be most appreciated…


Viewing 15 replies - 1 through 15 (of 19 total)
  • I mean the login form is separate…

    Tyler Regas


    I hate to ask this, but did you add the widget to your sidebar? I have it working on WP 3.1 with BP and S2members just fine without having to tweak any code (aside form appearance).

    I’m having the same issue, this plugin does not work at all. The various icons all show up on the wp-login screen, but all point to ‘javascript://’ and do nothing when clicked on. I ran the diagnostics option the plugin has and it says everything is good to go, but something is obviously wrong with this thing.

    Okay i figured it out, unfortunately this social-connect plugin seems to be incompatible with the very popular ‘white-label-cms’ plugin. Once I deactivated the white-label-cms plugin, then the http://javascript urls began opening their respective pop-up windows for each sign-in.

    With both plugins running, the ‘connect with’ buttons work on individual posts, sidebar widget (which i do not want to use), but fail on the all important wp-login screen while white-label-cms is activated alongside social-connect.

    Seems like this is something that could be corrected, since the similar janrain and gigya social login plugins have the same ‘pop-up’ functionality, but for some reason work fine alongside white-label-cms. Any help would be much appreciated, as this plugin seems like a great simpler alternative to other similar but bloated plugins.

    Plugin Author thenbrent


    Thanks for determining the issue. We’ll be releasing a new version soon so I will look into this before we make that release.

    Plugin Author thenbrent


    The problem is that White Label CMS is replacing the entire login form (unnecessarily).

    As a quick fix for the problem, you can remove this line from wlcms-plugin.php:

    I’ve contacted the devs to request they make appropriate changes. You can second the request if you like here:


    I am not using white-label-cms, and it doesn’t work for me either.

    I am running WordPress 3.1 with a port of P2 using the “Login with AJAX” plugin. ( I am able to see the icons below the plugin,
    but: the Facebook sends me this error:

    “error”: {
    “type”: “OAuthException”,
    “message”: “Invalid redirect_uri: Given URL is not allowed by the Application configuration.”
    The Twitter (if I’m logged in to twitter already) doesn’t log in. It just opens up the site in a little rectangular box in the upper left quadrant.

    Please note that I am using Social Connect out of the box with only including the correct keys and codes from FB and Twitter.

    Thank you.

    The URL you are trying to redirect the user to is being denied by the application.

    For example, this usually occurs when your application’s url is ( and your redirect uri is ( or even (

    I would verify all your settings are correct in the Facebook Developer App and try again.


    I am using Social Connect plug-in into my website.

    But when user redirect after given their details from FB, Twitter or Google it redirect to my site “undefined” (404) page !

    I checked all settings but still not found solution!

    Can anyone help me please ?

    Waiting for your support,



    The twitter and facebook logins are working for me, but the other 3 bring up the “not found” page. Can someone explain how to “Rewrite Diagnostics”?

    I’d also like to know how to move the icons above the name/email login, so people see there’s an easier way to login. Thanks!

    The plugin seems to work well on the register form. However I have no icons showing up out on the post page, just the text appears.


    I do not have a white-label-cms installed and neither any other Login form plugin. I have the latest version of WP (3.1.3) and of the plugin.

    Social Connect shows the icons on the login page, but if I click them, nothing happens… It is the same on the registration page. The test in the admin area works fine and I get no errors anywhere.

    The icons do not however appear in the comments login area…

    My website address is:

    Any ideas what might be the cause?

    Thanks and best regards,

    There is a potential fix for 404 errors –> have your hosting provider whitelist your domain on mod_security.

    I was getting 404 errors using the diagnostic URL at the bottom of the Social-Connect config page in WP and when when using Y!, Google, and

    For me, Y!/G/ would authenticate properly and pass the user back to my web site where they then would get a 404 error. I know this because the 404 page URL would have all the data from the third party including first name, last name, and email. You can see if this is the case for you by highlighting all text in the URL and pasting into a text document.

    My hosting company is Host Gator. I use WP 3.2.1 and Social Connect 0.7.

    I’m with Hostgator also. Thanks for the info!

    It works great
    You need also fill in the WEBSITE lower at the facebook APP
    The questions are under this link at the bottom
    “Select how your app integrates with Facebook”

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘Social Connect does not work at all’ is closed to new replies.