Support » Plugin: Reusable Content & Text Blocks by Loomisoft » So strange, please help

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Loomisoft

    (@loomisoft)

    Somehow there is an extra paragraph (p tag) kicking in that generates the second box in each column.

    Are you in any way able to send us the source for the content block to info@loomisoft.com?

    Hi,

    It seems hard for me to send you the source because I created it by SiteOrigin PageBuilder and there is no way to export the block (I think it’s good idea for your plugin’s feature, export the block)

    I can revert it to text editor then copy for you but that will not make sense because it will break the style. So I will describe the step-by-step I made that reusable block for you by using Siteorigin Pagebuider. If you have another idea, tell me.

    1. Add a row with at least 7 column
    2. Fill each column with a button in wire type.
    3. Each button links to a post

    That’s it! Can you try then tell me if it is ok or not

    Plugin Author Loomisoft

    (@loomisoft)

    It seems to be working at this end. Exactly what button text are you using? Just the number?

    Also, how are you embedding the block in the page? Via widget or shortcode?

    Plugin Author Loomisoft

    (@loomisoft)

    Hi @fususu

    We’ve tried to recreate the issue here but so far we haven’t managed to. Everything seems to be working fine.

    You actually can import/export from Site Origin … On the content block edit page, could you:

    • Click the Layouts button
    • On the popup that appears click Import/Export
    • Click the Download Layout button
    • Send us the json file you download

    Also, can you reconfirm:

    • Are you using Site Origin to edit the containing page?
    • How you are embedding in the page (e.g. via shortcode or widget)?

    Regards,

    Artem

    • This reply was modified 2 years, 9 months ago by Loomisoft.

    Thank you,

    I’ve sent you an editor account so you can login and see things you need on the back-end and front-end. That’s the quickest way 🙂

    Plugin Author Loomisoft

    (@loomisoft)

    Thanks for that.

    We duplicated your content block and page contents on our test site and we noticed that on our site, Site Origin produces the button code so:

    <div class=”so-widget-sow-button so-widget-sow-button-wire-04a92d42d0ef”><div class=”ow-button-base ow-button-align-center”>


    <span>

    1 </span>

    </div>
    </div>

    On your site that turns to:

    <div class=”so-widget-sow-button so-widget-sow-button-wire-cd9ae4249a18″><div class=”ow-button-base ow-button-align-center”><p> <br /> <span></p><p> 1 </span><br /> </div></div>

    It looks like another plugin might be running wpautop again and converting the extra carriage returns to <p> tags. It might be worthwhile turning off (and on) the other plugins one by one and seeing which it is.

    That way we can investigate more thoroughly what is going one

    • This reply was modified 2 years, 9 months ago by Loomisoft.
    • This reply was modified 2 years, 9 months ago by Loomisoft.
    • This reply was modified 2 years, 9 months ago by Loomisoft.
    • This reply was modified 2 years, 9 months ago by Loomisoft.

    I’ve figured it out. When I use the icon function of siteorigin button, everything is Ok. Except the height of the button seem to be sketched in size. Don’t know why. I’ve install a plugin that disable the wpautop() function, but that doesn’t help.

    The block alone: https://fususu.com/lscontentblock/10-scrolls-footer/
    When call in out: https://fususu.com/test-block/

    Hi fususu,

    Alex from SiteOrigin here. 🙂

    This typically is a sign of another plugin filtering the data as @loomisoft suggested in their last reply. I would recommend running a general plugin conflict test to try and work out what’s doing this.

    Can you please try disabling all non-SiteOrigin plugins (leave Reusable Content & Text Blocks by Loomisoft active) and see if this fixes the issue? You’ll need to clear all your caches after disabling your plugins.

    If it does fix the issue, then try re-enabling your plugins one by one until the issue comes back. This procedure will help diagnose which plugin is causing the issue.

    Once we know that, we’ll be able to look at what might be causing the conflict and either solve the problem (if possible) or help you find an alternative plugin.

    If you aren’t using a SiteOrigin theme, then you can also try temporarily switching to one of the default WordPress themes to see if the issue is theme related.

    If that doesn’t help, can you please export your content block? You can do this by opening the editor and then clicking the Layout button in the Page Builder toolbar. Select Import/Export on the left and click Download layout. Please upload the json file to a third party hosting site. A popular option is teknik.io

    @loomisoft Personally, I was unfamiliar with this plugin previously but I really quite like the look of it. I’m going to start recommending it to users who are after this sort of functionality. 🙂

    Plugin Author Loomisoft

    (@loomisoft)

    That’s probably because with an icon, Site Origin doesn’t put (as many) carriage returns so the extra <p> tags don’t get injected along the line.

    I must admit that wpautop is a core element of how WordPress processes content and disabling it might not be ideal.

    I think if you recreate the contents of the block straight into the page (i.e. not via content blocks) and if you still get the issue, then the problem is definitely elsewhere.

    Of course, for us it would be interesting to find out where exactly so we can include notes in our FAQs. So if you do find out, please let us know.

    Plugin Author Loomisoft

    (@loomisoft)

    Hi @alexgso

    Thanks for your comments. It’s funny I was reading this support article earlier https://siteorigin.com/thread/outputting-additional-p-tag/ so it’s really good to hear from you directly on this post. Agree with your suggestions to @fususu.

    Also, thanks for the vote of confidence. That would be great. All recommendations are greatly appreciated.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘So strange, please help’ is closed to new replies.