Support » Fixing WordPress » send_to_editor Javascript function not there

  • thecardboardtypewriter


    I am at the end of my rope.

    I’ve been scrolling through the forums and Googling my way around, trying to find the answer.

    Originally, I couldn’t enter text into the New Post body section (the title bar and notes sections were fine). I can only enter text if I disable the visual editor (because that makes sense).

    Now, I can’t insert photos. I uploaded them to the library. They show up. But next to them is the word “Show.” Clicking on it does nothing.

    I tried uploading new media straight from my computer. I get the same “Show” listing as the library.

    Finally, I manually entered in the URL. Here, I actually get a box with options like positioning and captions. However, I have two problems. 1.) The image title isn’t accepted…it never goes from the red asterisk to a green check mark (no matter what I write) and 2.) Clicking the “Insert Image” button does nothing. The page goes nowhere.

    What can I do?

    As a note: I just upgraded to 3.0. This is my first post so I can’t tell you if I was having problems before. I deactivated all plug-ins and went to the default theme.

    UPDATE: After viewing an error console and the source code, it seems my Insert Media page is missing a piece of Java Script called send_to_editor. Any ideas?

Viewing 5 replies - 1 through 5 (of 5 total)
  • thecardboardtypewriter





    The error console reads: “win.send_to_editor is not a function” when I press “Insert into Post.”



    Hello? Hello? I re-installed everything, just like the sticky advised, and nothing has changed.

    Should I just switch blogging hosts?

    Hi Alice.
    I had the same problem after upgrading to 3.0.1 and i finally fixed it!
    Seems Opera 10.10 has a bug (fixed in modern versions) that means createContextualFragment() (non-standard Mozilla’s extension to the Range object) is unreliable sometimes. Huh, yet another incompatibility issue between Opera and Tiny MCE. But i patched tiny_mce.js and now it works well. Download unpacked script from SourceForge and replace string

    /* Opera-specific bug workaround: createContextualFragment() loses child nodes */
    if (opera && opera.version() == '10.10')
    	var wa_frag = t.getRng().createContextualFragment(h);
    	var wa_stor = document.createElement('div');
    	wa_stor.innerHTML = h;
    	for (var curr, i=0; curr = wa_stor.childNodes[i]; i++)
    	opera.postError('Range.createContextualFragment() fix applied. See tiny_mce.js for details');
    else r.insertNode(t.getRng().createContextualFragment(h));

    If SCRIPT_DEBUG is not defined, then wp-tinymce.js.gz also need to be patched in a similar way.



    I’ve got the same problem. It seems to be a relic of the same problem from 2 years ago and I’m not sure what is triggering the edge case.

    3.0.1 site
    upload media, check
    insert media, blank screen of death
    — win.send_to_editor is not a function

    Deactivated plugins, cleared cache, same behavior.
    * Safari
    * FF
    * Chrome

    Relevant but not solved Trac link for devs:

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘send_to_editor Javascript function not there’ is closed to new replies.