Support » Plugin: Simple Calendar - Google Calendar Plugin » So buggy it’s unusable.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Same experience here. After some pain got the calendar appearing in my web site. Entered an event in the calendar and it showed up in the web site. Great so far. Entered another event in the calendar, it doesn’t show up in the web site. Delete the first event, it *still* shows up in the web site. No amount of burning browser history or fiddling with settings helps. I’m stuck with the first event I created in the calendar, which is no longer on the calendar but still published on my web site. Also, no subsequent events I put on the calendar ever propagate to the web site.

    • This reply was modified 7 months, 3 weeks ago by  kerrythurber.

    Hi kerrythurber,

    it’s me again.

    Every calendar has its own cache refresh interval. I think the default setting is two hours.

    You can clear the cache manually by clicking on “all calendars” in the menu, mark all calendar calendars and click on “clear cache” in the drop down menu.

    Maybe that helps.

    Greets, Klagstein

    That sounds like a great idea. I’m unable to navigate as you indicate, however. Are you on the wordpress site or the google calendar?

    wordpress-backend -> Calendars (it’s the plugin menu) -> All calendars -> select all -> drop down menu top left -> clear cache

    Found this in the FAQ:

    Why the event I just added on a Google Calendar doesn’t show up in Simple Calendar?
    Each calendar in Simple Calendar caches the events queried from Google for a period of time and updates them at periodic intervals. You can change the default maximum interval for each individual calendar, in the Advanced tab in the calendar settings panel. It is recommended you leave it at the default setting.

    My editorial: Who in the universe wants to wait two hours from the time you change your calendar to the time you see it reflected on your website? Who thought this was a good idea? I could understand two minutes in case I fell on the keyboard and didn’t want the website showing my mistake. Two hours is insane, and insulting, and uncalled for, and the recommendation is unaccompanied by a reason.
    Editorial off

    New question, same general question: The calendar only displays the current month and the following month. Who in the universe only cares about the next month in a calendar app? Is there a way to change this one? Does the premium version give you 3 months or something? Quickly leaning towards writing my own calendar plugin.

    Klagstein’s method of clearing the cache doesn’t help the calendar events propagate any faster, and in the latest version the advanced tab does not any longer contain an option to change the default maximum interval for any calendar anywhere. Who thought this stuff up?

    Oh kerrythurber, come down! I’ve got the feeling now, that you are not even trying.

    Sure there is still the option under the advanced tab.

    You can change the default maximum interval for each individual calendar, in the “Advanced tab” in the calendar settings panel.

    So go to the advacned tab of a calendar, not to the advanced tab from the plugin settings.

    writing my own calendar plugin

    Well, tell me when you finished the project, I will be glad to test your plugin. But meanwhile please check some information about HTTP requests and database queries. Both will increase when lowering the cache timeout and decrease the performance of your website for front-end and back-end users.

    I see no reason to lower the cache timeout. The users of my website want to check the events of a year. A event change wont cause any conclusion when delayed 2 hours (max). I save more than that time by changing events mobile with google calendar app instead of doing it at home or mobile in the wp back-end.

    Klagstein’s method of clearing the cache doesn’t help the calendar events propagate any faster

    Did you press the accept button after choosing “clear cache” from the drop down menu? Do you use any other cache plugin like “WP Super Cache” or similar?

    Is there a way to change this one?

    And again I’m guessing you did not even try to solve it for your self. Go to Calendar setting (NOT THE PLUGIN SETTINGS), go to the sub menu “events” and there choose the time range you want to display.

    Greetings,
    Klagstein

    Klagstein, I’ll try one more time when I get home, but I suspect you have an earlier version of this plugin than me. I am not seeing the settings advertised, and I do look pretty carefully. The fact that your particular business case does not suffer from a two hour delay is poor justification for having that as the default, but I’m glad it’s working for you. Yes, I did press the accept button after clearing the cache. I don’t believe that that particular setting is relevant here.

    Strike 3 I’m out. No such settings available on the Google Calendar, or on the plugin, or on the individual calendar settings within WP, or in any settings anywhere. Since Klagstein is so adamant I wonder if my issue is trying to do this on Bluehost. Is somebody else successful with these settings on wordpress.org?

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘So buggy it’s unusable.’ is closed to new replies.