Support » Installing WordPress » Snow Leopard

  • I’m really a novice when it comes to this stuff so I apologize for whatever obvious mistake I am making.

    I have been trying for a week to install wordpress for a website. I have watched several youtube videos. I get it. I make the database, I match the wp-config file. I upload it to an ftp site and here is where I get burned.

    I go to wp-admin/install.php and I get a broken link. I can go to the http://ftp.domainname.com site and I get a list of the wordpress file links. I looked at the code and it said I was not running php.

    So then I downloaded MAMP, and tried that out. I still get a broken link when it comes to the install.

    So now I am thinking that since I just bought this MacBook air, I must be missing something that translates php. I never purchased/installed Snow Leopard. Is this necessary in setting up wordpress on the back end of a website.

    Again, I apologize if this is a dumb question. I kind of jumped in head first, and I am about to break something if I get another error message.

Viewing 11 replies - 1 through 11 (of 11 total)
  • esmi

    (@esmi)

    Forum Moderator

    I upload it to an ftp site

    Do you have your own domain and hosting account on a remote server?

    Erik

    (@southernutahautism)

    Can you explain what you are doing a little more clearly?

    If you have a domain and FTP access, your computer shouldn’t matter. What you typically do is upload the wordpress files to your domain, create a mySQL database, and then run the wordpress installer. This will ask for your database name, user, password, and server, and then create a wp-config.php for you automatically and complete the setup.

    If you are trying to run wordpress off a Macbook Air, it won’t work unless you have a MAMP setup running and configured. WordPress requires Apache, mySQL and PHP to all be running, and most personal computers don’t have those things installed typically.

    I am not clear on where you are stuck: are you trying to upload this to a hosting server like Dreamhost, or are you trying to run Worpdress locally on your laptop?

    Thanks Erik! I am trying to upload wordpress to Laughing Squid hosting site. I set up a SQL database in the control panel of the site and then I downloaded Filezilla. I matched the wp-config file to the username and password in the database and then opened Filezilla. In the Remote Host folder, I couldn’t find a public html folder, so instead I used the file pathway that Laughing Squid sent me which was a web/content folder. I dropped the wordpress files there. Then it transfered the files. To the web/content/-wp-install/admin.php domain and instead of showing the install page of wordpress, it said the link was broken.

    Then I went to http://ftp.mydomainname.com. There was an index list of wordpress files. I read the code of the install file and it said that I wasn’t running PHP. So I downloaded MAMP. I named a database under myPHP admin. I matched the wp-config file to this new database. I dropped wordpress into the htc folder. Waited. Went to localhost/8888/wp-install/admin.php an again, no dice. I know I am missing something, I just can’t figure out what. Any help would be greatly appreciated!!

    Erik

    (@southernutahautism)

    You don’t need to create a wp-config.php file. If you create a database, and then run the wordpress installer, it will do it for you.

    There’s no way of knowing what you’re doing wrong without seeing a wp-config or your actual domain. Don’t post the database settings here on the forums, but you might want to link the domain you’re trying to use.

    Even with no database installed, when you go to the root folder for your wordpress install, you’ll see a screen that says

    There doesn’t seem to be a wp-config.php file. I need this before we can get started. Need more help? We got it. You can create a wp-config.php file through a web interface, but this doesn’t work for all server setups. The safest way is to manually create the file.

    If you can see that page, that means PHP is running, and you can proceed with the install. You don’t/shouldn’t browse to wp-install/admin.php.

    In fact, I don’t even see that directory in a fresh download of 3.1.

    Also, you shouldn’t be going to http://ftp.mydomainname.com to view files… why wouldn’t you go to http://www.mydomainname.com? If you are seeing the directory list of files, and there’s an “index.php” in that list, that means PHP isn’t running.

    I just barely fired up MAMP, downloaded wordpress 3.1, dragged the folder into where my MAMP is pointed to run, went right to the root folder, and it gave me the above message I put in the blockquote.

    You’re doing something outside of the normal install, I just can’t figure out what. There’s not even a wp-install folder in WordPress.

    also, you should be going to http://localhost:8888/Your_Wordpress_Directory/ and nowhere else.

    When I go to my domain link, nothing appears. It’s just blank.

    So I need to stick with MAMP, and not worry with the database I created in the control panel, or whatever I uploaded to Filezilla? I can watch another MAMP tutorial. Is there anything I should do to start from scratch? All I need is a hosting site, a wordpress download and MAMP, right?

    If you have a hosting site, you don’t need MAMP. MAMP is for you to install WordPress on your own computer for testing purposes.

    Choose which one you want to work on and stick with it. It sounds like you might be doing the steps in separate places.

    Ah. I misunderstood the testing tutorials for testing pages on a website, rather than testing wordpress on my mac outside of the web altogether. I some people need to run web functions on their computer to play with web design?

    Anyway, that has nothing to do with simply installing wordpress to my website? Correct? So all I have to do is follow these instructions on this video and I should be good to go? http://www.youtube.com/watch?v=cAkr_xbVXn0

    Ok, so I followed the instructions on the video. When I pulled up filezilla and entered my host name which is my domain name, it would not let me connect. Laughing squid said to use ftp3.ftptoyoursite.com instead. I did and it connected. I followed the instructions, uploaded wordpress to a new directory named blog. I went to the domain like he does in the video and all I get is a broken link. I went to the link that I used as the host name with the same path as demonstrated in the video and I still got a broken link. I imagine that I need to use my http://www.website.com as the host, but Filezilla will not connect. Any help would be greatly appreciated!

    Did you upload it to the publicly accessible directory? I’m not sure how laughing squid works but some hosts have a public_html directory.

    If you did that correctly, then you should visit <domainname.com>/blog
    Replace <domainname.com> with your own registered domain name. If that still doesn’t work, check if the domain has been registered correctly and that it points to your host.

    Erik

    (@southernutahautism)

    Do yourself a huge, huge, favor and ditch Laughing Squid and sign up for a Dreamhost account.

    Ok…got it.
    On Laughing Squid, your public folder is a /web/content folder.

    Here is the site…the music is pretty good if you get a chance to listen.
    http://www.sundayvalleyband.com/

    THANK YOU to everyone for all your help!..I really couldn’t have done it without you.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Snow Leopard’ is closed to new replies.