WordPress.org

Support

Support » Themes and Templates » Sneaky “ghost” CSS tags

Sneaky “ghost” CSS tags

  • Hi all-
    I’m trying to get my archives page to look like the normal front blog page. Easy, right? It’s practically the same code from index.php, except there’s get_exerpt instead of get_content and some other errata.

    Well, some document somewhere is overriding my CSS tags – for example, I have it set so it displays the posting, then under it is the comments tag and categories (on the right), with a border-bottom under all that, then the next post appears. However, my archives page is getting tags from a different source than the ones on archive.php so the comments/categories appear below the bottom border, when in fact they should be above as according to the tags I have set. There’s an outside set of tags that I recognize from the default theme (div.narrowcolumn#content) that show up instead of the ones I’ve specified in archives.php. (And narrowcolumn doesn’t exist on the style sheet I designed, so it’s messing everything up.)

    The quick solution would be to simply copy my tags and throw in the narrowcolumn and crap so it shows up… but it still doesn’t tell me what page is feeding into the archive.php and overwriting the tags I’ve already written.

    I’d love to give a sample, but unfortunately it’s on our dev server and is password protected. 🙁

Viewing 4 replies - 1 through 4 (of 4 total)
  • “narrowcolumn” tells me you are modifying the Deafult theme (Kubrick) which is a PITA for a newbie.
    For displaying a list of archived posts you have to use the archive.php template (no -s for plural at the end!!!).
    archives.php is a Page template.

    yes, I actually altered both. Sorry for the lack of clarification. 🙂

    The more annoying part is that I want my sidebar to *not* have any bullets in the list elements, and they show up anyway, no matter what page I edit (the css sheet, the settings in dashboard, etc.), and I’m fully convinced WP has some page that keeps overriding my settings.

    Mark (podz)

    @podz

    Support Maven

    Look for ‘before: 00BB’ or something similar in the css.
    That is giving the >>

    For the bullets in the sidebar, look for #sidebar ul, #sidebar ul ul { } and set list-style-type: none !important; that should fix that, removes all bullets for lists on the sidebar and either level.

    Jbbrwcky

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Sneaky “ghost” CSS tags’ is closed to new replies.