WordPress.org

Forums

The Support Forums will be in read-only mode for a scheduled maintenance window on 01 September 2016 14:00 UTC - 20:00 UTC. More information.

WP Smush - Image Optimization
[resolved] Smushit Only Working Manually (4 posts)

  1. ayoungvoice
    Member
    Posted 2 years ago #

    I'm able to smush my images manually but when I upload one into a post the image doesn't smush automatically. I have W3 Total Cache and Cloudflare. I recently installed Smushit. Is there something I'm missing? It works on another site I have.

    http://wordpress.org/plugins/wp-smushit/

    babyboomster.com

  2. Mike
    WPMU DEV Support Staff
    Posted 2 years ago #

    Hi @ayoungvoice

    WP Smush.it doesn't work with caching plugins, so that's probably the first problem here.

    Also the automatic smushing is only done when uploading images directly to the media library. The only way to smush them is to use the bulk smush.it option.

    Can you try with W3 Total Cache and CloudFlare disabled and see how it goes then?

  3. ayoungvoice
    Member
    Posted 2 years ago #

    I want to keep W3 Total Cache and Cloudflare so I'll just use the online smushit before uploading. Thanks for letting me know.

  4. Mike
    WPMU DEV Support Staff
    Posted 2 years ago #

    Ok no problem.

    But I only meant to disable as a test, then you can re-enable them. It's just to rule something out.

    If you are happy with this resolution then please mark this thread as resolved to help us keep on top of everything more efficiently :-)

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WP Smush - Image Optimization
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags