WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Smush.it not working

[Resolved] Smush.it not working

  • Have used the plugin before on other sites with great success. Installed on current site, and it simply doesn’t work. When I click Smush.it now! on an image in the media library, it works for longer than I would expect and then, when it stops working on it, nothing has changed. The file still shows as not processed.

    Here’s what I’ve tried: Deactivating and reactivating the plugin; uninstalling and reinstalling the plugin; disabling caching plugins that do anything to image files.

    Any help that can be provided would be appreciated.

    Thanks!

    http://wordpress.org/plugins/wp-smushit/

Viewing 5 replies - 1 through 5 (of 5 total)
  • @jbhphx,

    On the current version of the Smush.it plugin go to Settings > Media. Then look for the Smush.it section. Set the debug output option and save the options.

    Then go to Media > Bulk Smush.it and run the bulk smash.it. Let us know if you get any output.

    Lots of output. The common error is “No savings” but I know these images are not optimized. When I run them through Kraken I get as much as a 90% savings. Here’s an example of the output:

    DEBUG: attachment_file_path=[/home/content/e/l/e/elementds/html/99dollarsocial/wp-content/uploads/2013/09/300×2506.jpg]
    DEBUG: attachment_file_url=[http://www.99dollarsocial.com/wp-content/uploads/2013/09/300×2506.jpg]
    DEBUG: file_url [http://www.99dollarsocial.com/wp-content/uploads/2013/09/300×2506.jpg] home_url [http://www.99dollarsocial.com]
    DEBUG: Calling API: [http://www.smushit.com/ysmush.it/ws.php?img=http%3A%2F%2Fwww.99dollarsocial.com%2Fwp-content%2Fuploads%2F2013%2F09%2F300x2506.jpg]
    DEBUG: return from API: data

    stdClass Object
    (
    [src] => http://www.99dollarsocial.com/wp-content/uploads/2013/09/300×2506.jpg
    [src_size] => 89715
    [error] => No savings
    [dest_size] => -1
    [id] =>

    Mike

    @michael-copestake

    WPMU DEV Support Staff

    Hey there,

    I downloaded your image and uploaded it to my test site, which is using the latest version of WP Smush.it, it also reported no savings for me. I then tried a couple of other images and they Smushed and the amount saved was reported.

    Do other images work for you? Maybe it’s just not possible to optimize some of them.

    Thanks, Mike. It seems to be working well now. Not sure what the issue was before. I appreciate your help!

    Mike

    @michael-copestake

    WPMU DEV Support Staff

    That’s great, thanks for letting us know and for marking the thread resolved 🙂

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Resolved] Smush.it not working’ is closed to new replies.