Support » Plugins » Smush.it HTTP error on image upload

  • When I try to upload an image i get an HTTP error. The image information is there (like title, description, etc), but no images are generated.

    Additionally I use Cloudflare and W3C Total Cache, but I am 95% certain the issue is with the WP Smush.it plugin.

    I’ve disabled Cloudflare and W3C, but the HTTP error still persists, but disabling Smush.it allows media uploads to work again.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Same problem for me.

    The issue appeared in previous versions of SmushIt and then was rectified after WordPress 3.2.1 but now with the upgrade of WordPress to 3.3.2 the bug has reappeared.

    while i am sorry to hear you are having trouble, i’m a little relieved that it isn’t something i’ve done, or a problem w/ my configuration. if i had more time i’d try digging into the smush.it plugin, but for now i suppose i will just have to disable it.

    I did a but more digging into it and found a mention of a possible solution, though I’ve not tested it yet. Apparently the http problem arises mostly with .png format images. If you save images as ,jpg apparently that makes the issue less likely.

    Interesting. We most certainly wouldn’t the cause with CloudFlare turned off. At the same time, however, I would still recommend excluding the admin section of WordPress from CloudFlare to minimize future issues down the road with plugins.

    thanks for the tip on that… thanks to graham’s confirmation i’m certain it is a problem with the smush.it plugin and/or service.

    Could very well be. Not unusual for something to go wrong after a WordPress upgrade of sorts.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Smush.it HTTP error on image upload’ is closed to new replies.