Support » Plugin: Smush Image Compression and Optimization » smush wont load in admin / then crashes

  • Resolved chronicinternet

    (@chronicinternet)


    hello – I am unable to get smush to work. I had purchased this with the sweet dating theme plugin and they told me to contact you directly and make sure that cloudflare cloud was grey. Please advise as I need to smush my images, as my site is running slow.

    The page I need help with: [log in to see the link]

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Support Nastia – WPMU DEV Support

    (@wpmudev-support9)

    Hello @chronicinternet

    Hope you’re doing well!

    Please clarify what is the error showing up for you when images are smushed?

    After visiting your site I’m getting “ERR_CONNECTION_REFUSED”. This looks like a server related error and any access from external sources to your site is refused. This means that the WP Smush can’t contact our servers to optimize images.

    Please check your server’s error log for a more detailed explanation and contact your hosting provider about this error.

    Kind regards,
    Nastia

    I have not deactivated the plugin so you should be able to login and fix this issue please.

    what is the status of this?

    Plugin Author Anton Vanyukov

    (@vanyukov)

    Hi @chronicinternet,

    I am getting timeout errors when trying to view your site or scan it with PageSpeed/Gtmetrix. If those tools cannot reach your site, our API won’t as well. Please fix the server issues and Smush will work. I would recommend you disable all the plugins and start activating them one by one to see which one is causing the issue. If that does not help, you will need to contact your host to get some insight on what is happening on your server that is causing such issues.

    Best regards,
    Anton

    As I had mentioned – I have disabled all of the plugins. There is absolutely no reason why you cannot login to admin. There are 12vCPU and 48 GB of memory. GTX cannot access because of cloudflare – which I have turned off.

    As I had mentioned, this is on a cloud server – THERE IS NO HOSTING COMPANY – there is an issue with SMUSH that is not loading. I am asking you to fix it because Sweet Dating Theme says its up to you.

    THERE IS NO HOSTING COMPANY – THE SERVER IS RUNNING FINE. YOU NEED TO LOG IN – PAGE SPEED DOES NOT WORK WITH SITE EITHER

    Plugin Author Anton Vanyukov

    (@vanyukov)

    Hi @chronicinternet,

    Sorry, but I do not have access to your site and cannot login and check anything. We are not affiliated with Sweet Dating Theme in any way. And I am not aware of what they have done/checked on your site and why they referred you to the WordPress support forums.

    I have checked your site and provided you with the reason why Smush is not working – the site is not accessible. If it does not load within 30 seconds, it will timeout with our API. If this is not caused by any plugin/theme, this is a misconfiguration on the server. Please understand that in order for Smush to work it needs to have a working connection to our API. Until this issue is resolved, none of the external tools will be able to communicate with your site (that includes PageSpeed, Gtmetrix, Smush, etc.).

    Best regards,
    Anton

    I had given you access to my site – what do you need – are you just avoiding the bug?

    Plugin Author Anton Vanyukov

    (@vanyukov)

    @chronicinternet,

    Sorry, but you have not given us any access. Smush is not related to Sweet Dating Theme. I will help you as much as I can, but you need to resolve the connection issue first.

    Best regards,
    Anton

    the connection issue is fixed I had passed it through gtmetrix and google speed but it is still only loading. I need to compress all my images

    Plugin Author Anton Vanyukov

    (@vanyukov)

    Hi @chronicinternet,

    Awesome! Now your front page is loading for me and I can see that you are using Polish functionality from Cloudflare to optimize your images. All your images are optimized at the moment. If you prefer to use Smush instead, you can disable Polish in your Cloudflare account in the Speed – Polish settings. After that you can optimize images through the media library or via bulk Smush (50 images at a time with the free version of Smush), or configure auto smush so that the images are compressed on upload.

    Best regards,
    Anton

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘smush wont load in admin / then crashes’ is closed to new replies.