Support » Plugin: Smush Image Compression and Optimization » Smush Lazy Loading hiding images

  • Resolved Mailgun

    (@mailgun)


    I updated to Smush 3.2.2.1 and experienced issues with the lazy loading feature. Images were being hidden and not displayed.

    I have three screenshots I can submit: what it should look like, the issue and a snippet of code from the issue area.

    (the snippet of code shows the image tag with a lazy-hidden class, an empty data-src attribute and an encrypted src value.)

    I had to deactivate lazy loading.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Support Dimitris – WPMU DEV Support

    (@wpmudev-support6)

    Hello @mailgun

    I have three screenshots I can submit: what it should look like, the issue and a snippet of code from the issue area.

    Could you please send me an email to contact@wpmudev.org using this template:

    Subject: “Attn: Dimitris

    Message: link back to this thread for reference

    Keep in mind the subject line as ensures that it gets assigned to me.

    Thank you,
    Dimitris

    Hello

    i’ve got this kind of probleme clearly identified : when setting lazy loading my logo doesn’t show up anymore
    then it doesn’t appear anymore in my search console

    why is that ?

    thanks

    nicolas

    Plugin Author Anton Vanyukov

    (@vanyukov)

    Hi @carideal ,

    Could you please try do this fix. In the plugin folder in file core/modules/class-wp-smush-lazy-load.php on line 281 remove
    WP_Smush_Page_Parser::add_attribute( $new_image, 'data-sizes', 'auto' );

    Best regards,
    Anton

    Plugin Support Dimitris – WPMU DEV Support

    (@wpmudev-support6)

    Hello there @mailgun

    It’s been a while since we’ve heard back from you so I mark this topic as resolved. Feel free to post any updates here or create a new topic and we’ll be glad to continue troubleshooting. 🙂

    @carideal as this may be another issue than the originally reported here, please do create a separate topic about it so we can further investigate.

    Thank you,
    Dimitris

    nikhilmodi

    (@nikhilmodi)

    Hello,
    I activated lazy load but my product page images or not loading.
    Check this link
    https://daltonking.com/p/auto-sensing-toilet-light/

    Plugin Author Anton Vanyukov

    (@vanyukov)

    Hi @nikhilmodi,

    All the images are showing fine for me in the link that you posted.

    Best regards,
    Anton

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.