Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author Sayontan

    (@sayontan)

    Your nick_name would be goensouth. If you look at the shortcode insertion popup (visible via Add Media → Photonic → SmugMug) it mentions: If your SmugMug URL is http://joe-sixpack.smugmug.com, this is “joe-sixpack”. Required if the “Display” is “Tree” or “All albums”.

    What are you trying to display? What shortcode are you using?

    [gallery type='smugmug' view='albums' nick_name='goensouth' filter='TmwLp6']

    I also tried without filter. Trying to display:

    Plugin Author Sayontan

    (@sayontan)

    When I look at the source code for your page, I see no occurrences of the shortcode. That leads me to think that your theme or one of your plugins also defines its own version of the gallery shortcode. To get around this, use the very first option of Photonic: under Photonic → Settings → Generic Options → Generic Settings → Custom Shortcode, define a custom shortcode, e.g. photonic. Once you do that, you can change your shortcode to use photonic (or whatever you define as your custom shortcode) instead of gallery.

    Thank you, progress I’m now seeing single image. How do I set things so rows of thumbnails appear?

    Plugin Author Sayontan

    (@sayontan)

    The shortcode you are using is meant to show top-level albums, not images within them. If you click on the image that is showing up, it will open up a lightbox and start showing all images in that album. If you remove the filter attribute, it will show one thumbnail for each album.

    Do you want to show all images from a single album? In that case, use the shortcode as documented here: https://aquoid.com/plugins/photonic/smugmug/smugmug-photos/

    Super, thank you. How do I decrease the padding around the photos? Making changes in Album Thumbnails (with other Albums) and Photos (Main Page) isn’t having any effect.

    Plugin Author Sayontan

    (@sayontan)

    As of now, you are using a 4-column layout, which assigns each block around 24% of the total width, meaning that 4% of your width is unused (4 = 100 – 24*4). So, when I look at your site on a large screen (i.e. a 27″ monitor), the photos show up as a little bit more spaced out, since 4% of the width is considerable. If you want, you may use the “Constrain by padding” option and not explicitly define the number of thumbnails you are using.

    Alternatively you might consider using the justified grid layout, or any of the other layouts as documented here: https://aquoid.com/plugins/photonic/layouts/

    This worked for me:
    .photonic-thumb {
    padding: 0!important;
    }

    .photonic-thumb a img {
    padding: 3px 5px!important;
    }

    Thank you for everything. Much appreciated!

    I added layout=’mosaic’ but now only seeing nothing or loading spinner. Tried on Chrome and Edge. In gist I want this page:

    https://goensouthevents.com/smug-mug-test/

    to display photos identical to:

    Plugin Author Sayontan

    (@sayontan)

    It shows up, but it takes a long time to do so. The primary reason for this is likely the number of images and the size of each. You might want to try the following for optimization:

    • Consider using a different “tile size”, and set it to something smaller than the “main image”. When you click on an image it will still show up full-sized in the lightbox.
    • Consider using the more attribute of the shortcode and only show around 20-30 images to start with.
    • Also consider using the random layout instead of the mosaic layout – it is slightly less JavaScript-intensive.

    How do I use a different “tile size”, and set it to something smaller than the “main image”?

    Plugin Author Sayontan

    (@sayontan)

    You can do this from Photonic → Settings → SmugMug → SmugMug Settings → Tile image size. Is this what you are aking for?

    • This reply was modified 1 year, 5 months ago by  Sayontan.

    Perfect, thanks much

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Smug Album not showing’ is closed to new replies.