Support » Everything else WordPress » SMTP settings for Outlook.com?

  • I am trying to setup SMTP settings for my domain which I use Live Domains for.

    No matter what plugin I use for SMTP email and use the following settings:

    Outlook.com SMTP server address: smtp.live.com
    Outlook.com SMTP user name: full Outlook.com
    Outlook.com SMTP password: Outlook.com password
    Outlook.com SMTP port: 587
    Outlook.com SMTP TLS/SSL encryption required: yes

    No email gets sent. It just returns errors. Does anyone know how to setup this properly?

Viewing 4 replies - 1 through 4 (of 4 total)
  • Chris Olbekson

    (@c3mdigital)

    Level 12 Bug Squasher & Forum Moderator

    Hi Edtek,

    Sounds like the SMPT port 587 is blocked by your webhost. I know many hosts block alternate ports but usually they will open them up for you if you request. I would start with your webhost first to see if the port is blocked.

    Hi Chris,
    I am having the same problem.
    How to check that port is blocked.

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    Ask your webhost.

    European

    (@europeannetworks)

    There is possible a firewall problem. First of all check your domain is configured right in your ‘live’ dashboard then, if not helps, contact your hosting provider.

    To test the ports use this simple script in php:

    $host = 'smtp.outlook.com';
    $ports = array(25, 587);
    
    foreach ($ports as $port)
    {
        $connection = @fsockopen($host, $port);
    
        if (is_resource($connection))
        {
            echo '<h2>' . $host . ':' . $port . ' ' . '(' . getservbyport($port, 'tcp') . ') is open.</h2>' . "\n";
    
            fclose($connection);
        }
    
        else
        {
            echo '<h2>' . $host . ':' . $port . ' is not responding.</h2>' . "\n";
        }
    }
Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘SMTP settings for Outlook.com?’ is closed to new replies.