Support » Plugin: SparkPost » SMTP Method (Port 587 and Port 2525) does not work

Viewing 15 replies - 1 through 15 (of 16 total)
  • Plugin Contributor rajuru

    (@rajuru)

    SMTP did not work because your server’s firewall is blocking outgoing connection of port 587 and 2525.

    Hello,
    Thanks for your answer.

    My ISP is AT&T and I ran a “telnet” test on my computer (Macbook) and here is what I got:

    MyComputer:~ Myself$ telnet outbound.att.net 587
    Trying 67.195.15.5…
    Connected to smtp.att.mail.fy4.b.yahoo.com.
    Escape character is ‘^]’.
    220 smtp.mail.att.net ESMTP ready
    Connection closed by foreign host.

    MyComputer:~ Myself$ telnet outbound.att.net 2525
    Trying 98.138.84.52…
    telnet: connect to address 98.138.84.52: Operation timed out
    Trying 67.195.15.5…
    telnet: connect to address 67.195.15.5: Operation timed out
    telnet: Unable to connect to remote host

    So if I understand well I am supposed to be able to use the port 587, am I not?

    Anyway if I stick to the HTTP API method that works what is the deal? Am I going to face any kind of problem?

    Thanks for your time.

    Regards,
    Oxley

    ———————————————

    Last minute correction.
    May be I should add this found here:
    https://forums.att.com/t5/U-verse-email/Update-Email-Server-Settings-for-AT-amp-T-Email/m-p/4312314

    POP Server: inbound.att.net
    SMTP Server: outbound.att.net (requires authentication)
    Mail Ports: Incoming Mail Port #995: SSL Checked; Outgoing Mail Port #465: SSL Checked

    Hi again,
    I got an answer from AT&T:

    Incoming email (POP3 or IMAP)…
    inbound.att.net port 995 requires SSL selected

    Outgoing email (SMTP)…
    outbound.att.net port 465 requires SSL selected

    So the test I ran was the right one.

    Regards,
    Oxley

    Plugin Contributor rajuru

    (@rajuru)

    You’re telnet’ing from your computer? That’s actually inbound for the server. Try to telnet sparkpost (587, 2525) from inside your server.

    HTTP works because it works on port 80/443 which is generally open everywhere. You won’t face issues unless not everything supported in HTTP yet. Test it with your use cases and if things work like you want. If there are issues please post on https://github.com/SparkPost/wordpress-sparkpost which is easier to track.

    Thanks

    Hello,

    “You’re telnet’ing from your computer? That’s actually inbound for the server. Try to telnet sparkpost (587, 2525) from inside your server.”

    I am sorry but I don’t follow you. How can I telnet Sparkpost from inside my server? I don’t know how to do this.

    ————————————————————————

    Here is what I did. On my hosting company site I found this article:

    ———————————

    CHECKING YOUR OUTGOING MAIL SERVER (IS PORT 25 BLOCKED?)

    INSTRUCTIONS

    Type the following command:
    telnet example.com 25

    View Results:
    If Port 25 is not blocked, you will get a successful 220 response (text may vary).

    Trying 64.13.192.208…
    Connected to example.com.
    Escape character is ‘^]’.
    220 cl34.gs01.gridserver.com ESMTP Exim 4.63 Tue, 24 Jun 2008 13:45:04 -0700

    If Port 25 is blocked, you will get a connection error or no response at all.
    Trying 64.13.192.208…
    telnet: connect to address 64.13.192.208: Connection refused
    telnet: Unable to connect to remote host

    You can use this same technique to check if Port 587 is blocked as well. Just use the following command:
    telnet example.com 587

    ———————————

    So unless I miss something using the terminal of my computer I have just followed what they recommend to do ?

    ————————————————————————

    Could you tell me how to telnet Sparkpost from inside my server?

    Thanks in advance for your answer.

    Regards,
    Oxley

    Plugin Contributor rajuru

    (@rajuru)

    You can ssh to your server where the wordpress site (plugin) is installed. Then telnet from there.

    telnet smtp.sparkpostmail.com 587

    Rajuru,

    Given what I wrote above you can see that computing is not my background. Unfortunately…
    Would you, please, tell me in a more understandable way what to do?

    I have followed a tutorial provided by my website’s hosting company. It seems that for you that was not the right thing to do:
    “You’re telnet’ing from your computer? That’s actually inbound for the server. Try to telnet sparkpost (587, 2525) from inside your server.”

    So I replied:
    “I am sorry but I don’t follow you. How can I telnet Sparkpost from inside my server? I don’t know how to do this.”

    And now you suggest that: “You can ssh to your server where the wordpress site (plugin) is installed. Then telnet from there.”

    How to “ssh from my server”? It seems cool but you just get me lost..

    ——

    I still don’t get why doing so when my hosting company just suggests to test the port with telnet from my computer. Anyway I am ready to follow your advice. I just dont know to ssh from my server.

    Would you share your knowledge with me and make me your “apprentice”? For sure the Force of the ssh is strong with you.

    Thanks in advance.
    Regards,
    Oxley

    Hi Oxley – I would highly recommend you just scrap using SMTP and use select the HTTP API option in the SparkPost plugin settings screen. This will allow you to bypass any blocks your hosting provider might have in place as it just uses HTTPS (port 443).

    Hello richleland,

    Thank you for your answer. At least now, I know it is ok to use the HTTP API!
    Do you have a suggestion for an IP I should test running a telnet test?

    ==> telnet example.com 587

    What to put instead of example.com?
    Again, thank you for your help.

    Regards,
    Oxley

    Yep it’s smtp.sparkpostmail.com for SMTP.

    SMTP did not work because your server’s firewall is blocking outgoing connection of port 587 and 2525.

    I think I’ve got the same problem,

    I’ve tried all 3 methods, port 587, 2525 and HTTP API and the send via
    SMTP permission is enabled.

    I have also installed another SMTP plugin called “WP Mail SMTP” with the
    settings here
    https://support.sparkpost.com/customer/en/portal/articles/1988470-smtp-connection-problems
    but this other plugin also does not work. So maybe it might be my
    settings in wordpress, sparkpost or firewall.

    I’ve got hostgator shared hosting and the sparkpost plugin intsalled.

    1.) Do you know how I can fix this so the sparkpost plugin works with
    wordpress?

    2.) How do I change the firewall so its not blocking port 587 and 2525 (sorry I’m a noobie)?

    Here is a screenshot of the error: http://screencast.com/t/9gkgoEC9m

    Regards
    Jono

    Plugin Contributor rajuru

    (@rajuru)

    @jono543
    From the screenshot, it looks like your port is not blocked. Your domain (where wordpress is installed) doesn’t match your registered sending domain. Please specify From email in the settings panel using a domain that you’ve added (and verified) in sparkpost.

    Thanks for your reply,

    in Admin > settings > Sparkpost the “From email” is support@MyDomain.com

    I have verified the domain by SPF, DKIM and Email. I have also copied and pasted the domain into the Sparkpost plugin From email field to avoid any typing mistakes but I’m still getting the same error.

    1.) Do you want me to email you my WP admin login?
    2.) Any more suggestion?

    Plugin Contributor rajuru

    (@rajuru)

    @jono543
    If you join #wordpress channel, I’ll try to help you there.
    https://sparkpost-community.slack.com/messages/wordpress

    (Find raju over there 🙂 )

    I can’t join, I don’t have a @sparkpost.com email

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘SMTP Method (Port 587 and Port 2525) does not work’ is closed to new replies.