Support » Plugin: WP Mail SMTP by WPForms » SMTP Error: Could not authenticate

  • Resolved selym

    (@selym)


    Hi everyone! I use my web hosts SMTP server for mail. I updated this plugin from 2.0.1 to 2.1.1 yesterday and it appears I can no longer send email from my site. I confirmed my smtp user/password are correct. Looks like others are also having issues. Has anyone come up with some common things to check?

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Author Gregor Capuder

    (@capuderg)

    Hi @selym,

    so, you are using the “Other SMTP” mailer?

    What does the “full debug log” say when you try to send an “Email test” (the debug log link should appear after an error occurs when the Email test fails at the bottom of the page)? Please copy-paste the content of that debug log here.

    Could you please verify, that the plugin update broke your SMTP email sending? You can do that by downgrading the plugin version from 2.1.1 to 2.0.1. You can find the older version of the plugin here: https://wordpress.org/plugins/wp-mail-smtp/advanced/ at the bottom of the page.

    Thanks and take care!

    Hi Gregor-

    Yep, using “Other SMTP” mailer config.
    I downgraded back to 2.0.1 and unfortunately still have the issue.
    The debug log (taken with 2.1.1 installed) is below.
    FYI, I did open a ticket with my host first as it looked like it was a server side issue, but when I came here and saw others having issues with the latest update, I figured it was worth asking here too.

    Versions:
    WordPress: 5.4.2
    WordPress MS: No
    PHP: 7.3.18
    WP Mail SMTP: 2.1.1

    Params:
    Mailer: smtp
    Constants: No
    ErrorInfo: SMTP Error: Could not authenticate.
    Host: nyc-sd015.hawkhost.com
    Port: 465
    SMTPSecure: ssl
    SMTPAutoTLS: bool(false)
    SMTPAuth: bool(true)

    Server:
    OpenSSL: OpenSSL 1.0.2k 26 Jan 2017
    Apache.mod_security: No

    Debug:
    Mailer: Other SMTP
    SMTP Error: Could not authenticate.

    SMTP Debug:
    2020-06-12 13:15:11 Connection: opening to ssl://nyc-sd015.hawkhost.com:465, timeout=300, options=array ()

    2020-06-12 13:15:11 Connection: opened

    2020-06-12 13:15:11 SERVER -> CLIENT: 220-nyc-sd015.hawkhost.com ESMTP Exim 4.93 #2 Fri, 12 Jun 2020 09:15:11 -0400 220-We do not authorize the use of this system to transport unsolicited, 220 and/or bulk e-mail.

    2020-06-12 13:15:11 CLIENT -> SERVER: EHLO http://www.redacteddomain.com

    2020-06-12 13:15:11 SERVER -> CLIENT: 250-nyc-sd015.hawkhost.com Hello http://www.redacteddomain.com [172.96.187.7]250-SIZE 52428800250-8BITMIME250-PIPELINING250-AUTH PLAIN LOGIN250 HELP

    2020-06-12 13:15:11 CLIENT -> SERVER: AUTH LOGIN

    2020-06-12 13:15:11 SERVER -> CLIENT: 334 VXNlcm5hbWU6

    2020-06-12 13:15:11 CLIENT -> SERVER: dGFkZHlAdGFkZHlib29rLmNvbQ==

    2020-06-12 13:15:11 SERVER -> CLIENT: 334 UGFzc3dvcmQ6

    2020-06-12 13:15:11 CLIENT -> SERVER:

    2020-06-12 13:15:13 SERVER -> CLIENT: 535 Incorrect authentication data

    2020-06-12 13:15:13 SMTP ERROR: Password command failed: 535 Incorrect authentication data

    SMTP Error: Could not authenticate.

    2020-06-12 13:15:13 CLIENT -> SERVER: QUIT

    2020-06-12 13:15:13 SERVER -> CLIENT: 221 nyc-sd015.hawkhost.com closing connection

    2020-06-12 13:15:13 Connection: closed

    SMTP Error: Could not authenticate.

    Plugin Author Gregor Capuder

    (@capuderg)

    Hi,

    you did the correct thing by contacting your hosting support. As you can see your WP site is trying to connect to the SMTP server, but it is refused because of

    SMTP ERROR: Password command failed: 535 Incorrect authentication data

    Please let us know what the outcome of the conversation with your hosting support will be, maybe it will help some other users as well.

    Take care!

    My hosting support found that in wp-config.php, define( ‘WPMS_ON’, true );
    was now disabled, so the only explanation they could offer is that it was caused by my recent WordPress upgrade.

    Plugin Author Gregor Capuder

    (@capuderg)

    Hi @selym,

    thank you for sharing this with us.

    This is very strange. So, you were using constants to set up the “Other SMTP” mailer password and the password constant was still present in the wp-config.php file, just the main plugin enabling constant define( ‘WPMS_ON’, true ); was missing?

    In the log above it says Constants: No, so I just assumed you were not using constants and that you updated the SMTP username and password in the plugin settings inputs (saved to the database).

    Anyway, adding the main plugin enabling constant define( ‘WPMS_ON’, true ); probably resolved the issue for you, right?

    Take care!

    Hi Gregor,

    I agree, it sounds strange to me too. From what they said (quoted below), it sounds to me like the code was still present but now said “false” and they changed to true. I should follow up for clarification, but I’m really just happy it’s working again.

    “The below code was disabled under the wp-config file which caused the issue. I have now enabled by changing to true.”

    Hi guys, I’ve the same issue but plugin works, it’s just show me often SMTP autentication error message from front end but its send message. In wp-config already still have define( ‘WPMS_ON’, true );

    Why show me error message with TRUE and with works? How to fix?

    Plugin Author Gregor Capuder

    (@capuderg)

    Hi @shaovel,

    do you have the constants code in wp-config.php above the line: /* That's all, stop editing! Happy publishing. */.

    Please verify that. Your constants code should be above the line mentioned above.

    Having them below this line may cause issues for certain WP core emails.

    Take care!

    Hi @capuderg I don’t understand well what your mean, can you explain more?
    Thanks!

    Plugin Author Gregor Capuder

    (@capuderg)

    Hi,

    make sure the plugin constants code is above the /* That's all, stop editing! Happy publishing. */ line in the wp-config.php file.

    See this image, for clarification.

    Take care!

    Hi again @capuderg
    I have this now, please look:
    Screenshot

    @capuderg have u see? Tnx

    Plugin Author Gregor Capuder

    (@capuderg)

    Hi @shaovel,

    I just see two lines of code in your screenshot and I don’t see where the /* That's all, stop editing! Happy publishing. */ line is…

    Does your wp-config.php file have the line /* That's all, stop editing! Happy publishing. */ in it?

    Take care!

    Hi again @capuderg , now I’ve understand and do like you said! Already was code line but not up, I fixed! Thanks

    Plugin Author Gregor Capuder

    (@capuderg)

    Hi @shaovel,

    I’m glad this issue is fixed for you 🙂

    Have a nice day!

Viewing 15 replies - 1 through 15 (of 15 total)
  • You must be logged in to reply to this topic.