Support » Plugin: WP Mail SMTP by WPForms » SMTP Email Not working even after config

  • ananddevops

    (@ananddevops)


    Hello,

    I have activated the plugin and was trying to configure Gmail SMTP server as provided in this Link

    Also see my setting screenshot of WP Admin. All details are correct on this page, triple checked.

    When I try the Email Test after setup it fails, giving error
    Could not authenticate your SMTP account

    But all my details are correct.

    Kindly suggest.
    Thanks

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author Slava Abakumov

    (@slaffik)

    Hello,

    Please provide the whole output of the debug message when you send using Email Test.
    Do you use 2FA for your Google account?

    No, I have not activated 2FA for the same. But Google has come up with trusting devices with setting. I am not sure if that affects the same.

    I have also used zoho smtp settings, with no 2FA, and even the same doesn’t seems to be working.

    Could you help me understand what you mean by debug message? I am newbie to WP. I don’t get any error, if thats what you mean. My settings are saved perfectly fine without any error.

    On further diggin I am came across with some known issues with email to with server contig I am using. Will resolve the same and revisit incase I still face an issue.

    Plugin Author Slava Abakumov

    (@slaffik)

    @ananddevops
    Great, thanks for the update. I’m resolving the thread meanwhile.

    Regarding Email Test
    This is what I was talking about: http://cloud.supportally.com/eeb9c2424162

    Ok, so I have finished the first part of checking and making configuration changes at my end. Let me explain so we can discuss the matter further.

    1. I am using the – WP setup and as you see, it suggests WP Mail SMTP.
    2. I configured the plugin, as mentioned in this thread earlier.
    3. When it didn’t work, I got know and issue that AWS throttles port 25 i.e the default SMTP port.
    4. So I had the 25 port unthrottled from the server end.
    5. I tried the Email Test again and got the following error. See

    Anything I can test further at my end to see where exactly the problem might be?

    Thanks

    Plugin Author Slava Abakumov

    (@slaffik)

    At the very bottom of the error message there is a link: Click here to view the full Error Log for debugging.
    I need the content of that full debug output.

    Also to update, that I have run the same test with and without 2FA email acoounts and the result is the same, and so is the log except the Invalid 2FA line.

    @slaffik

    Did the error log help to determine the issue or direction?

    @slaffik

    Just to update that the gmail smtp WORKS on two conditions set in the Gmail account

    1. “Enable less secure apps to access accounts”
    2. Disable 2FA

    Both of these settings makes the Gmail account vulenerable security wise and not recommended. So is there another way to make the email setup work without compromising security?

    OAuth 2 needs to do the same hence that too isn’t an option.

    Awaiting any possible resolutions/workarounds that you can provide or is this a known condition?

    Plugin Author Slava Abakumov

    (@slaffik)

    If you use Gmail mailer (and define Client ID/Secret ):
    This is your own app, that you created and only you have access to it. So it’s safe in this case to enable less secure apps. Just don’t allow other apps (that you have not created) to access your data.

    2FA for both Gmail and “Other SMTP” mailer:
    With 2FA it should actually work. Please consult with 2FA documentation from Google: https://support.google.com/a/answer/1032419 and similar articles.

    2FA for “Other SMTP” mailer:
    You need to use not the Google password for SMTP connection, but something else, generated specifically for that connection. I don’t remember where I read that, but you can google it.

    @slaffik

    Thanks for the acknowledging the known issues. Let me try some settings and tests at my end and will upadte the thread.

    @slaffik I came across this restriction.

    Seems like les secure apps don’t work with 2FA.

    Also I had missed out on setting mentioned here

    They are :

    SMTP hosts =
    SMTP port = 25
    SMTP security = TLs
    SMTP username: USERNAME
    SMTP password: PASSWORD
    From address: EMAIL_ADDRESS

    In the wp-config.php. If I put these details in wp-config.php HOW do I do that actual code piece and where in the file?

    Your thoughts, Will mails start working post that?

    Thanks

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘SMTP Email Not working even after config’ is closed to new replies.