Support » Plugin: SMTP Mailing Queue » smtp credential are not saved permanently

  • Resolved Faisal Ahmed

    (@fftfaisal)


    I have installed this plugin on my site. it is working fine as my need. but the problem is SMTP credentials are not saved permanently on my site. I have saved that today . when I coming into the admin side after 2 or 3 days I see smtp password field is empty. As a result, all queued email is failed. my customer can not get an email. it is very bad for my business. I have already used wp smtp plugin, easy smtp plugin. but the problem was smtp email send is too late almost 1 minute , I am using qq smtp mail. thats the problem and that why I am using your queue email for get red of stuck 1 min for process order email.

    MY wp version: 5.4.1

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author Birmania

    (@birmania)

    Hi @fftfaisal,

    I am sincerely sorry for the inconvenience caused to your customers.
    This behavior is very strange ! Does it occurs once or mutiple times ?
    Is password the only field that have been lost ?
    Which version of the plugin did you install at first ? Prior to 1.2.0 ?

    On version 1.2.0, an upgrade was done to use better cryptographic algorithm for password storage. So, updating from 1.1.0 to 1.2.0 should decrypt/re-encrypt the password and should be transparent but maybe something goes wrong during the process ?

    I did not succeed to reproduce this on my dev environemnt but I would be pleased to dig more in order to discover what happened and how to avoid/fix this.

    Yours faithfully,
    Birmania

    Faisal Ahmed

    (@fftfaisal)

    yes. it has occurred multiple times. I was installed 1.1.0 at first then upgrade to 1.2.0. If you can be fixed this issue, then please let me know. otherwise I need to change plugin 🙁

    Best Regards
    Faisal

    Plugin Author Birmania

    (@birmania)

    O.K ! Did this problem occurs before upgrading to 1.2.0 ?
    Password was the only field reset or other fields from settings have been reset too ?
    Did you find a way to reproduce this without waiting some days ?

    The fact that this reset is not immediate let me think that it may come from some cron that run and and broke smq options but it seems very strange !

    If you can, please give me :
    – PHP version
    – Plugins installed and their versions

    Yours faithfully,
    Birmania

    Faisal Ahmed

    (@fftfaisal)

    I can not remember that, I see the problem in the version 1.2.0
    yes. only the password field has been reset and shows empty.

    I am basically login into my site after 2-5 days. and see this problem .. all emails are in the failure list. also, log in when a customer told me they didn’t get email.

    I am using php 7.4.6
    here is my plugin list
    image link

    Plugin Author Birmania

    (@birmania)

    Just run some tests with PHP 7.4.6 and everything seems fine yet.

    The only way I successfully reset the password was by modifying “smq_version” option in wp_options table, changing value from “1.2.0” to “1.1.1”.
    By doing this, update to 1.2.0 execute again and, as password is already in new encryption, the decrypt/encrypt result in password being empty string.

    Do you have any process that could modify/rollback sqm_version value in database ?
    Note : “smq_version” is written on “plugins_loaded” action.

    Faisal Ahmed

    (@fftfaisal)

    ok, I have updated the smq_version option in the options table to 1.1.1 from 1.2.0. After doing it, I am going to the SMTP setting page and again see blank value in the password field. I have again put a password to save the setting. but now I again see in the database it shows up smq_version is 1.2.0.

    What Should I do now? I have all access DB, file manager all. I am a developer also. I can easily save the SMTP password as plain text in the DB. but I am waiting for your result so it will help me with the plugin future update.

    thank you

    Plugin Author Birmania

    (@birmania)

    I remember a very strange notice that another user got :
    https://wordpress.org/support/topic/php-notices-in-log/

    This class instance is accessed using “global” which seems a bit weird.
    I just made changes in order to pass object through constructor which may be safer ?

    I will upload a new version (1.2.1) in the evening, could you update your website and report me in the next days if problem occurs again please ?

    • This reply was modified 6 months ago by Birmania.
    Plugin Author Birmania

    (@birmania)

    Important Note :
    Version 1.2.1 is broken, please use version 1.2.2.

    Faisal Ahmed

    (@fftfaisal)

    in the 1.2.0 it happened again I was last update password 9 hours ago. and now see the field is blank. now I have update plugin into to 1.2.2, and again save password field. let see after couple of hours, if it is still keep blank value

    Faisal Ahmed

    (@fftfaisal)

    problem is solved after update to 1.2.2

    one quetion. How to I clear failure email list ?

    Plugin Author Birmania

    (@birmania)

    Hi @fftfaisal,

    Happy to read that this new version fixed the SMTP password reset problem !
    I just published a new version of the plugin (1.3.0) which bring tool new capabilities.
    On invalid mails list you can now purge all failed mail or bulk action delete/retry them.

    Let me know if you encounter any issue during the clearance.
    Yours fathfully,
    Birmania

    Hi, I am using version 1.3.1 and the password is being reset for me too, the same as described above.

    Plugin Author Birmania

    (@birmania)

    Hi @hardwidge,

    I tried to reproduce the problem through multiple method without success.
    The only way to reproduce this is to manualy set an old version in “smq_version” wp_option and let the migration tool process your SMTP password.

    Is your WordPress Multisite ? What is your PHP and WP version ?
    Do you have some plugins which modify wp_options or rollback some of them ?

    Yours faithfully,
    Birmania

Viewing 13 replies - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.