Support » Plugin: WP SMS » SMS Global Deactive Status

  • mythos1717



    I just bought credits and got a number activated with the SMS Global platform. I have copied and pasted the API username and password and also the API Key that is generated within the software and this is the error message that I am receiving: The HMAC-SHA authentication failed on mac

    I did look and saw a similar support ticket where the resolution was to use the API secret rather than the key, but when I do that, I get Unknown Authentication Error as the result.

    I am not sure what’s going on here, but wanted to reach out and see if you had any ideas. I have also reached out to SMS Global to make sure that there is nothing else that needs to happen on their end.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Hello,

    Can you please get me an answer or a possible solution. I am working on integrating this into a client’s website.

    Plugin Author Mostafa Soufi


    Sorry for the delayed reply to your question, I completely agree that gateway is a little difficult to config, so here is an instruction for that.

    First, go to your “SMSGlobal panel > API & Integrations” and then copy the REST API key and the secret.
    After that, go to your gateway settings page and set it up like the image that I’ve attached.

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.