Support » Plugin: Joli Table Of Contents » Smooth scrolling

  • Resolved imbinchin

    (@imbinchin)


    Hi,

    I’m an user of Joli content pro.
    The Smooth scrolling functionality is not work when the the anchor link contained Chinese characters. This bug is occurred after update to the latest version.
    Please help me to solve this issue. Thank you.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 18 total)
  • Plugin Author WPJoli

    (@wpjoli)

    Hi there,

    Since the last version, Joli TOC has been supporting non latin characters for anchor names. However, this created a small bug in the javascript that you pointed out.

    The issue has already been identified, and there will be a minor patch today. Watch your dashboard 😉

    Thank you

    Thread Starter imbinchin

    (@imbinchin)

    Hi there,

    I have update to the latest one. But still have this issue.

    Plugin Author WPJoli

    (@wpjoli)

    Hey,

    So sorry, something went wrong during deployment! I had to push another minor update.

    Can you check now and let me know ?

    Thank you!

    Thread Starter imbinchin

    (@imbinchin)

    Hi,

    It works now.
    But still have some issue when clicks the anchor link.

    Please check the following screen video.
    https://www.loom.com/share/8a604d58ceb0462b80f352fb47d7ca00

    • This reply was modified 6 months ago by imbinchin.
    Plugin Author WPJoli

    (@wpjoli)

    I’m not quite sure how to understand the problem on your video because I can’t reproduce it.

    Could you describe what you are experiencing ?

    Also, using non latin characters in the anchors make an error from “nectar-frontend.min.js”, which is outside of Joli TOC’s scope but it picks up on the anchors for some reason. Maybe that could create a conflict.

    Do you know where this file come from ? (plugin or theme)

    At last, I could implement an option to prevent non latin characters from being in the anchor slugs.

    Thread Starter imbinchin

    (@imbinchin)

    Hi,

    I have a part of FAQ in my post and setup the answer with the anchor links.
    When the anchor links only with latin characters, the smooth scrolling functionality works properly.
    But if the anchor links contain non latin characters, it will jump to the answer part without smooth scrolling.

    If you would like to reproduce this issue.
    1. access to https://www.twosevenths.com/handcraft/metalworking-taipei-activity/
    2. find the part named “0. 台北金工體驗快速評比”
    3. the third question has two answer. One is latin characters, another one is non latin characters. You can try it and will reproduce the issue.

    “nectar-frontend.min.js”
    This file come from theme.

    Plugin Author WPJoli

    (@wpjoli)

    Ok, I understand now.

    It turns out when you click from a link outside of Joli TOC, the scroll is handled by the file “nectar-frontend.min.js”. And this file generates an error with non latin characters.

    Joli TOC only handles smooth scrolling from the links clicked inside the table of contents. Anything outside is handled by third-party javascript if any (your theme in this case). You can try to deactivate smooth scrolling from the Joli TOC options and normally it still should work as your theme is handling that already.

    The problem lies within your theme that cannot handle properly non latin anchors.

    The only way I can see right now is to provide an option to force latin (auto-generated) characters only for the anchors.

    What do you think ?

    Thread Starter imbinchin

    (@imbinchin)

    Hi,

    I think it would be great.

    Plugin Author WPJoli

    (@wpjoli)

    Great! let me get back to you soon.

    Cheers

    Plugin Author WPJoli

    (@wpjoli)

    Hi,

    I’ve released a new update.

    There is now a new section in the options to choose the hash format.

    You can either choose a counter, non-latin character, or the transliteration of non-latin characters.

    Have this solved your issue ?

    Thread Starter imbinchin

    (@imbinchin)

    Hi,

    After updated to the latest version, the floating functionality is gone.
    https://imgur.com/HBWz5Kl

    Plugin Author WPJoli

    (@wpjoli)

    Hey so sorry about this,

    For some reason the pro settings didn’t get processed while deploying…

    There is fix in progress right now, please wait a moment.
    Also make sure your pro license is well activated.

    Thank you 🙂

    Plugin Author WPJoli

    (@wpjoli)

    Can you update to 1.3.4 now ?

    It should be okay now!

    Thread Starter imbinchin

    (@imbinchin)

    Hi,

    There is no update info till now.
    https://imgur.com/Bb54I0I

    Plugin Author WPJoli

    (@wpjoli)

    Can you check again now ?

Viewing 15 replies - 1 through 15 (of 18 total)
  • You must be logged in to reply to this topic.