WordPress.org

Support

Support » How-To and Troubleshooting » Smilies sometimes not showing up

Smilies sometimes not showing up

  • Hello.

    I am currently working on my site.
    My smilies only show up when there is a space before the smiley, which is fine for me when I’m posting, but I want them to show up for commenters too, whether or not there is a space before the smiley.

    Can anyone help me?

    I’m using the latest WP, 1.5.1.3

Viewing 3 replies - 1 through 3 (of 3 total)
  • If you take a look at the file vars.php in wp-includes you’ll see the list of smileys available. If you want, you can remove the space in front of the facial expressions but that may cause smileys in places where they are not intended. Perhaps you could provide clickable smileys for your commenters? That way they’d also know about the whole selection instead of just the basic ones. Alex King has a hack, but I don’t know if there’s a plugin…

    thanks minna, for giving me an answer and more info.
    sounds like the clickable smileys will be the way to go.

    thanks for your answer, again. I thought my post would go unnoticed. 🙂

    I noticed the hack is a plugin after all: WP Grins. My bad 🙂 It’s for 1.2 but I have it working on my 1.5.1.3.

    The instructions (if I remember correctly…) are the same for the comment area, but if you want the smileys for posts as well, there is a different place you have to put the code. I can dig it out if you want.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Smilies sometimes not showing up’ is closed to new replies.