WordPress.org

Support

Support » Alpha/Beta » Smilies in the Admin screens

Smilies in the Admin screens

  • Mark (podz)

    @podz

    Support Maven

    1. Can they be reintroduced ?
    or
    2. Can you make the wp_grins plugin work for that area please ?

    I don’t use them there, but many many many people do and if there is no solution, it’ll be a VFAQ.

Viewing 13 replies - 1 through 13 (of 13 total)
  • wp_grins works with a minor edit, so long as the WYSIWYG editor isn’t in use.

    Might be worth making an edited version available from http://dev.wp-plugins.org/

    question.. my wp grins used to work in 1.5 using this

    http://wordpress.org/support/topic/24409

    but in 2.0 the code is different.. any idea where do I add the code to make it work in the admin panel? ?_?

    thanks 🙂

    First, you need to edit wp-grins.php so that it looks in the right place for the smilies:

    Change
    $grins .= '<img src="'.get_settings('siteurl').'/wp-images/smilies/'.$grin.'" alt="'.$tag.'"

    to
    $grins .= '<img src="'.get_settings('siteurl').'/wp-includes/images/smilies/'.$grin.'" alt="'.$tag.'"

    Then you’ll need to edit wp-admin\admin-functions.php. Find <div id="quicktags"> and edit so it looks like this:

    <div id="quicktags">
    <script src="../wp-includes/js/quicktags.js" type="text/javascript"></script>
    <script type="text/javascript">if ( typeof tinyMCE == "undefined" || tinyMCE.configs.length < 1 ) edToolbar();</script>
    </div>
    ';
    if (function_exists("wp_grins")) { echo "
    "; wp_grins(); }

    This will only work if you are not using the rich text editor.

    As always, back up files before editing.

    Thanks, it’s working now.. 🙂

    “This will only work if you are not using the rich text editor.”

    Just curious to know how to turn off the “rich text editor”

    /wp-admin/users – in your profile, scroll down to the bottom, uncheck the box.

    or you can stick the wp-grins tag into edit-form-advance.php in the admin directory anywhere near the textbox. i made it so that it’s in its own drop down tab box, similar to ‘categories’, ‘timestamp’, etc.

    elani2…how can i group the smilies in a drop down box? should the rich text editor be disabled as well?

    notice how the drop down boxes are within the ‘fieldset’ tags? duplicate that, but modify so that the title and the content are different (‘Smilies’ and wp_grins tag).

    When I post this:
    <div id=”quicktags”>
    <script src=”../wp-includes/js/quicktags.js” type=”text/javascript”></script>
    <script type=”text/javascript”>if ( typeof tinyMCE == “undefined” || tinyMCE.configs.length < 1 ) edToolbar();</script>
    </div>
    ‘;
    if (function_exists(“wp_grins”)) { echo “
    “; wp_grins(); }
    ‘;
    else echo ‘

    I get this:
    =========================
    Parse error: parse error, unexpected T_STRING in /home/chronos/public_html/blog/wp-admin/admin-functions.php on line 1097
    =============================

    If I post only this:
    <div id=”quicktags”>
    <script src=”../wp-includes/js/quicktags.js” type=”text/javascript”></script>
    <script type=”text/javascript”>if ( typeof tinyMCE == “undefined” || tinyMCE.configs.length < 1 ) edToolbar();</script>
    </div>
    ‘;
    if (function_exists(“wp_grins”)) { echo “
    “; wp_grins(); }

    I get this instead:
    =================================
    Parse error: parse error, unexpected ‘<‘ in /home/chronos/public_html/blog/wp-admin/admin-functions.php on line 1095
    ==============================

    If I didn’t anything in the admin-functions.php, it seems to work ok. I’m confused. ^^ I don’t know anything about php so I’m not sure if I don’t edit anything in the admin-functions.php, it will be safe. ^^

    Oh! And I edited the wp-grins.php like LesBessant said and added <?php wp_grins(); ?> on wp-admin/edit-form.php, wp-admin/edit-form-advanced.php and wp-admin/edit-form-comment.php since there’s no wp-admin/quicktags.php

    Thanks for helping.

    styril: Try this instead to see if it works, works for me 🙂

    http://comox.textdrive.com/pipermail/wp-testers/2005-November/000555.html

    I can see the Smilies in the posting area, but can’t click on them 🙁 Any idea?

    The smilies works fine at my comments but if i would edit a comment or write a new blogentry i can’t click on them.

    Hello,

    Got it to work, but oh so miss the rich txt format.

    Is there anyway to get this to work with “rich Text Format” enabled?

    Thanks
    Fess

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Smilies in the Admin screens’ is closed to new replies.