Support » Plugin: Smarter Navigation » Smarter Navigation Not working in 3.6 with Toolbox

  • ipreferpencils

    (@ipreferpencils)


    Hi,
    I have a theme based on Automattic’s toolbox and using wordpress 3.6 and Simple Navigation doesn’t seem to be working.

    They place their post navigation code in their functions.php and I have changed

    <?php previous_post_link( '<div class="nav-previous">%link</div>', '<span class="meta-nav">' . _x( '←', 'Previous post link', 'toolbox' ) . '</span> Previous Drawing' ); ?>
    		<?php next_post_link( '<div class="nav-next">%link</div>', 'Next Drawing <span class="meta-nav">' . _x( '→', 'Next post link', 'toolbox' ) . '</span>' ); ?>

    to

    <?php previous_post_smart( '<div class="nav-previous">%link</div>', '<span class="meta-nav">' . _x( '←', 'Previous post link', 'toolbox' ) . '</span> Previous Drawing' ); ?>
    		<?php next_post_smart( '<div class="nav-next">%link</div>', 'Next Drawing <span class="meta-nav">' . _x( '→', 'Next post link', 'toolbox' ) . '</span>' ); ?>

    [Moderator Note: Please post code & markup between backticks or use the code button. Your posted code may now have been permanently damaged by the forum’s parser.]

    But the previous and next links still won’t stay within the category.

    I have tried it with permalinks set to %postname% and %category%/%postname%

    Any ideas?

    Thank you.

    http://wordpress.org/plugins/smarter-navigation/

Viewing 1 replies (of 1 total)
  • Thread Starter ipreferpencils

    (@ipreferpencils)

    I should also mention I have no parent or child categories set up and my settings have my home as a static page and my blog on a separate page.

Viewing 1 replies (of 1 total)
  • The topic ‘Smarter Navigation Not working in 3.6 with Toolbox’ is closed to new replies.