Support » Plugin: Smart Slider 3 » Smart Slider 3.4 & footnotes

  • Resolved check2020de

    (@check2020de)


    Since I have updated to 3.4 I have an issue when the plugin “footnotes” is active

    I have a slider with an shadow. In the imag you see the white spce which is exactly the spae of the slider (don’t know if with or without shadow).

    https://dlgo.de/smartslider.png

    When I deactivate footnotes the slider is working. Before 3.4 the slider was working together with footnotes.

    Any ideea how to solve this?

Viewing 10 replies - 16 through 25 (of 25 total)
  • check2020de

    (@check2020de)

    Footnotes is by far the best and most customizable footnote plugin. It looks like with the default settings it isn’t working together with Smart Slider any longer… but do to the fact that it is by far the best footnote plugin (there are very less availabe) it should work with default settings.

    What have I done? I changed the identifier (( and )) to (- and -)… and the issue is gone.

    The question for me is now if you can fix it so that the default (( and )) is working or do I need to update all my post to (- and -)?

    If you could fix it, it would be best because it would work for everyone with the default settings. Changing the identifier would be only a workarround, not a solution

    Plugin Support Ramona (from Nextend)

    (@nextend_ramona)

    Hi @check2020de

    Can you go to Global settings > Framework: https://smartslider.helpscoutdocs.com/article/1785-framework
    and change the “Slider’s inline JavaScript” to “Head”, if it’t not set to that yet?

    Head is the default setting there, but I think I was able to reproduce the issue you’re seeing by changing it to “Into the slider”.

    check2020de

    (@check2020de)

    Great, you are right… it was set to “Into the slider”. I changed it to “head” and it is working.

    If it is set to “Into the slider” it won’t affect the loading time of the site. Everything whicis in the head will have an effect… Please correct me if I’m wrong.

    Can we get it working with “Into the slider” ?? 🙂

    Plugin Support Ramona (from Nextend)

    (@nextend_ramona)

    Hi @check2020de

    Great! Then I’m able to reproduce this issue. I’ve just reported it for our developers to check and fix this ASAP, and I’ll let you know when its done.

    Everything you put into your site affect the loading speed. Though I haven’t tested the speed effect the “Slider’s inline JavaScript” option specifically, I don’t really think it gives much difference.

    check2020de

    (@check2020de)

    Great 🙂 Thanks so much

    Another point is, that with “header” the script will be loaded on all pages, doesn’t matter if a slider is on the page, right?

    Plugin Support Ramona (from Nextend)

    (@nextend_ramona)

    No, the slider should only load its codes on the pages where you actually have a published slider. (Regardless of the “Slider’s inline JavaScript” setting.)

    Do you see codes from Smart Slider in other pages, where you don’t actually have any sliders?

    check2020de

    (@check2020de)

    I haven’t checked it, just thought it would load on every page with “header”… but great if I’m wrong here.

    Can’t double check it now… it’s 10pm and I’m on my couch 🙂

    Plugin Author Nextendweb

    (@nextendweb)

    @check2020de I’m glad that Ramona was able to reproduce this bug. To be honest, we won’t be able to solve this inside Smart Slider 3, but I know several workarounds, so you can keep Smart Slider updated.

    These fixes are independent from each other and the most suggested solution is the first one:

    #1: In the Footnotes -> Settings -> Styling: Do not use (( )) format for start and end tag. They might match other codes which they should not. I think it is best to use [ref][/ref] which is a shortcode so it works flawlessly with every other plugin.

    #2: As Ramona suggested, set Smart Slider to inject their JavaScript and CSS to the head.

    #3: The following will moves the Footnote’s processing before the WordPress shortcode processing:
    Create a file: /wp-content/mu-plugins/fix-footnotes.php
    Content:

    <?php
    
    add_action('plugins_loaded', function () {
        global $g_obj_MCI_Footnotes;
    
        if (isset($g_obj_MCI_Footnotes)) {
            $task = $g_obj_MCI_Footnotes->a_obj_Task;
    
            if (MCI_Footnotes_Convert::toBool(MCI_Footnotes_Settings::instance()
                                                                    ->get(MCI_Footnotes_Settings::C_BOOL_EXPERT_LOOKUP_THE_CONTENT))) {
                remove_filter('the_content', array(
                    $task,
                    "the_content"
                ), PHP_INT_MAX);
    
                add_filter('the_content', array(
                    $task,
                    "the_content"
                ), 10);
            }
        }
    });
    check2020de

    (@check2020de)

    Thanks @nextendweb & @nextend_ramona !!! This is an amazing support.

    I understand that it is best to change the start and end tag becuase the default canause issues everywhere. Good to see that with default settings of Smart Slider and Footnotes everything is working!

    The code you wrote is great, thanks for spending so much time for it. Think for the one or other, this is an option. I went for changing the tags, which was a bit difficult because of different search results for (( and )) with in the post table… but now it is done 🙂

    Plugin Author Nextendweb

    (@nextendweb)

    @check2020de, it’s great that those solutions worked fine and sorry for the trouble. 🙂

Viewing 10 replies - 16 through 25 (of 25 total)
  • You must be logged in to reply to this topic.