Support » Plugin: Smart Slider 3 » Smart Slider 3.4.1.15 & WP Rocket Issue

  • Resolved a223123131

    (@a223123131)


    I just updated from 3.4.1.14 to 3.4.1.15 and with this from PHP 7.4 to PHP 8.

    What happened? I just saw a white area instead of a slider 🙁

    The reason was WP Rocket. Under “File Optimization” I have “Combine JavaScript files” enabled. This was working with 3.4.1.14, but not with 3.4.1.15.

    Any idea what has changed that this is in issue with 3.4.1.15?

    However under “Exclude JavaScript Files” I added the following line:
    /wp-content/cache/nextend/web/combined/(.*).js

    Now everything is working…. but I would be happy if I could remove this line so it is working like within 3.4.1.14. Any chance?

    • This topic was modified 3 months, 1 week ago by a223123131.
Viewing 15 replies - 1 through 15 (of 16 total)
  • Thread Starter a223123131

    (@a223123131)

    Funny… now I checked it again and it isn’t working again 🙁 Now I need to disable the entire “Combine JavaScript files” functionality which makes my site load slower.

    So to say switching back to PHP7.4 and 3.4.1.14 with “Combine JavaScript files” enabled makes my site much faster.

    • This reply was modified 3 months, 1 week ago by a223123131.
    • This reply was modified 3 months, 1 week ago by a223123131.
    • This reply was modified 3 months, 1 week ago by a223123131.
    Plugin Support Gabor

    (@nextendweb_gabor)

    Hi @a223123131!

    Could you send me a link to your website? Then we will take a look at what issue we see!

    You could contact us here, if you wouldn’t like to share your website’s link publicly:
    https://smartslider3.com/contact-us/support/?topic=Loading&platform=WordPress&version=Free

    Thread Starter a223123131

    (@a223123131)

    It’s going back and forward. Looks like the issue that my workarround didn’t worked was a temporary issue. It’s gone now and my workarround is working again.

    Unfortunatelly I have it only on the local test environment and can’t show it to you.

    Thread Starter a223123131

    (@a223123131)

    Looks like it’s something strange on my end… Now I have combined activated and the extra line removed. It is working 🙂

    Caches are not active. So I need to look deeper at my installation. Posted it because the extra line was the solution to help others, too.

    However, thanks for offering your help that quick… like allways. Your support is realy outstanding. Think about switching to Pro to support your support 🙂

    Thread Starter a223123131

    (@a223123131)

    I was able to reproduce it on a blank WP installation, just sent you everything through your link

    Thread Starter a223123131

    (@a223123131)

    If you Setup a new WP Installation and install SS3 Free and WP Rocket with the settings I sent you, you will have the same issue on your installation.

    As told, I’m ussing PHP 8.0

    Thread Starter a223123131

    (@a223123131)

    @nextendweb_gabor Are you able to reproduce it on your installation?

    Plugin Support Gabor

    (@nextendweb_gabor)

    Thanks for the help in this matter! We debugged your usecase and I just wrote to your email, so please check that!

    Plugin Support Ramona (from Nextend)

    (@nextend_ramona)

    Hi,

    We figured out the problem. In short, it happened because a conflicting piece of code was supposed to be removed from WP Rocket in a given version, and we had a patch that contained a version check, so it wasn’t running on newer WP Rocket versions.

    We’re removing that version check in the next release, which is scheduled around February.

    Thread Starter a223123131

    (@a223123131)

    Patch is working… thanks for the amazing quick support!!!

    Hello it looks like we might be having the same issue. After we updated WP Rocket and Smart Slider our slider is MIA. Can someone send me the patch?

    Thanks

    Forgot to mention that we’re on Version 3.8.2 of WPR. Is that version still affected?

    Plugin Support Ramona (from Nextend)

    (@nextend_ramona)

    Hi @twisted8000

    You can download it at:
    https://www.dropbox.com/s/6veks3lmdn2jvpm/smart-slider3-wordpress-free-wprocket.zip?dl=1

    You should just go to your Plugins list, delete your current Smart Slider 3 (don’t worry, your sliders will stay) and install the patched version like this:
    https://smartslider.helpscoutdocs.com/article/1717-wordpress-installation
    and it should fix the issue for you as well.

    Thread Starter a223123131

    (@a223123131)

    It looks like the issue is starting with WP Rocket 3.8.0.1. 3.8 and lower is working. I have also 3.8.2

    Just noticed we’re on the pro version. Is there a fix for the pro version?

Viewing 15 replies - 1 through 15 (of 16 total)
  • You must be logged in to reply to this topic.