Support » Plugin: Smart 404 » Smart 404 not working in 3.1.1

  • I installed it, activated it and confirmed the default setting in admin.
    But when I type a URL pointing nowhere, I still get the standard 404 page.

Viewing 9 replies - 1 through 9 (of 9 total)
  • You need to open your 404.php file in your themes directory and add

    <?php smart404_suggestions() ?>

    inbetween you content div – or main body div

    even after I placed the code into the 404.php file I cannot get this to work.
    Help please

    no results, looks like not working on WP 3.2?

    Initially I had problems with nothing been displayed on the 404 error page however I realised after looking closely I was putting the “<?php smart404_suggestions() ?>” code in the wrong place within my themes 404.php.

    I can confirm I am running WordPress V3.2.1 and the plugin V0.5 is working correctly.

    If nothing is being displayed you may need to look a little closer at your themes code to find the correct place.

    It looks like the:


    function is not working on latest wordpress versions

    I had it in place in my 404 pages but I noticed only today that it stopped working, while trying to implement that in another WP site I am running.

    Any chances of a fix?

    Yeah it’s causing a redirect loop.

    Plugin Author michaeltyson


    Hey – can you give more details of the circumstances under which you’re seeing the problem? I don’t seem to have any issues on my WP 3.2.1 installations (e.g.

    When I enable Smart 404 any page with a 404 will throw a redirect loop. There really aren’t any other details beyond that.

    Anyone got a solution to this or another similar 404 solution that works?

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Smart 404 not working in 3.1.1’ is closed to new replies.