Support » Plugin: TablePress » small styling question

  • Resolved holdportals

    (@holdportals)


    Hi Tobias
    I am using a wide table,
    when i shrink the screen the table is not shrunk correctly with the page, so using dev tools I found that changing this styling works well:

    element.style {
        width: 100%;
    }

    when hovering on the selector I see this line:
    table#tablepress-1.tablepress.tablepress-id-1.dataTable.no-footer.dtr-inline.collapsed

    question is where and what exactly should I specify in order to change the styling so that it will affect all tables I create.

    thanks
    table

    • This topic was modified 4 years, 1 month ago by holdportals.
Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author TobiasBg

    (@tobiasbg)

    Hi,

    thanks for your post, and sorry for the trouble.

    I’m a bit confused here, as the default for TablePress tables is

    .tablepress {
      width: 100%;
    }

    That is, the table should have 100% width already… Can you please post a link to the page with the table where this problem happens, so that I can take a direct look? Thanks!

    Regards,
    Tobias

    Thread Starter holdportals

    (@holdportals)

    Hi Tobias
    it is currently locally on my wamp environment.
    I will try to upload it

    Thread Starter holdportals

    (@holdportals)

    Hi Tobias
    Here it is: https://goo.gl/RnROcl

    Plugin Author TobiasBg

    (@tobiasbg)

    Hi,

    ah, I see. There seems to be an issue with the Responsive Tables Extension. Coincidentally, that received an update yesterday (version 1.4).
    Could you please install that (from https://tablepress.org/extensions/responsive-tables/ )? (As it’s not in the WordPress Plugin Directory, you’ll have to delete the old version and then install the new one.)
    This might then already fix this problem.

    If that does not help, we can indeed try to force the width to 100%. For that, add this to the “Custom CSS” textarea on the “Plugin Options” screen of TablePress:

    .tablepress-id-1 {
      width: 100% !important;
    }

    Regards,
    Tobias

    Thread Starter holdportals

    (@holdportals)

    I installed the new plugin, but this did not solve the problem.
    however the custom CSS did the fix. 🙂

    10x

    Plugin Author TobiasBg

    (@tobiasbg)

    Hi,

    great! Thanks for the confirmation!

    Best wishes,
    Tobias

    P.S.: In case you haven’t, please rate TablePress here in the plugin directory. Thanks!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘small styling question’ is closed to new replies.