Support » Plugin: CSV Importer » Small has_cap bug fix for CSV Importer

  • Am currently using the 0.3.6 version of CSV Importer, but having just turned on WP_DEBUG, was met with one of those has_cap messages:

    has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead.

    To get rid of this message (and with thanks to vonkanehaffen in this post thread) it looks as though we would need to edit Line 535 in csv_importer.php

    from add_management_page('edit.php', 'CSV Importer', 9, __FILE__, array($plugin, 'form'));

    to something like add_management_page('edit.php', 'CSV Importer', 'edit_plugins', __FILE__, array($plugin, 'form'));

    http://wordpress.org/extend/plugins/csv-importer/

  • The topic ‘Small has_cap bug fix for CSV Importer’ is closed to new replies.