Support » Plugin: External Links - nofollow, noopener & new window » Small function, big improvement

  • Resolved marcorroma

    (@marcorroma)


    Hi,
    I use the newspaper theme, with page builder tagDiv composer.
    This page builder uses cloud blocks. If I enable “Exceptions – Apply settings on: – All contents (the whole page)” I cannot upload the contents to the cloud to be able to import them into my site (pages, post block, etc.).
    (This problem was detected by the developers of tagDiv)

    This “All contents (the whole page)” setting has also caused me 2 problems in the past.
    No solution is known.
    Why don’t you think of a simple function to disable this exclusion if a user is logged in?
    This way your plugin works only on pages that are displayed to non-logged in users. It doesn’t prevent other plugins from working properly, and fixes some issues on publishing some posts with “JSON” error.

    Thanks for your time

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author WebFactory

    (@webfactory)

    Hi,
    I’ll see if we can add the “disable plugin for logged-in users” option.

    Thread Starter marcorroma

    (@marcorroma)

    Is there a php function to disable the “Exceptions – Apply settings on: – All contents (the whole page)” function for the logged in editors or users?

    Was there a .js file not to load?
    Or other quick temporary methods?

    Thank you!

    PS. If you set the topic as “Resolved” no emails notifying new responses are sent.

    • This reply was modified 5 months, 1 week ago by marcorroma.
    Plugin Author WebFactory

    (@webfactory)

    I don’t know of any quick or temporary solutions for this problem.

    Thread Starter marcorroma

    (@marcorroma)

    It is enough to disable the plugin for the post edit page.
    What is the point of having the function active in the backend?
    Disabling the external link management function in the backend would solve the problem and there would be no conflicts.

    Thread Starter marcorroma

    (@marcorroma)

    Don’t take my last message into consideration.

    A conflict with the “WP User Avatar” plugin has been detected.
    Try setting “exceptions – all contents (the whole page)”
    Then create a post, copying the text from this content (it’s a doc file):
    https://filebin.net/td2bmu7i154frzot/redazionale_20_di_24_da_pubblicare_il_16_aprile__2_.zip?t=th6y99ff

    You will get an error message. Correct?
    Thanks for support.

    • This reply was modified 4 months, 3 weeks ago by marcorroma.
    Plugin Author WebFactory

    (@webfactory)

    It’s a known conflict. We don’t have a fix at this time.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.