WordPress.org

Forums

Small Errors Need Fix! Please help (8 posts)

  1. legitptc
    Member
    Posted 7 years ago #

    I just finished switching hosts and a friend has done the switch so everything looked right until i go to log in.

    The username and password he provided me with when i was hosted by him was admin and the password was (no need to say)...i get two errors on the login page at the top it says.

    --------

    Warning: Cannot modify header information - headers already sent by (output started at /home/believe1/public_html/wp-config.php:47) in /home/believe1/public_html/wp-login.php on line 12

    Warning: Cannot modify header information - headers already sent by (output started at /home/believe1/public_html/wp-config.php:47) in /home/believe1/public_html/wp-login.php on line 24

    -------

    and when i use the log in he gave me which i had be using for my blog the whole time while i was hosted by him i get this message when i press enter:

    --------
    ERROR: WordPress requires Cookies but your browser does not support them or they are blocked.

    Also if i type www. infront of my domain name my blog doesnt show up.

    Please i need help, i am very new to wordpress and have checked some threads with my problems but havent been able to understand them! :(

    Any help would be amazingly appreciated.

  2. whooami
    Member
    Posted 7 years ago #

    Warning: Cannot modify header information - headers already sent by (output started at /home/believe1/public_html/wp-config.php:47) in /home/believe1/public_html/wp-login.php on line 12

    solve that error first.

    Its caused by a line break OR spaces after the closing ?> in your wp-config.php

  3. legitptc
    Member
    Posted 7 years ago #

    This is all that is in my wp-config.php

    <?php

    // ** MySQL settings ** //

    define('DB_NAME', 'believe1_wrdp5'); // The name of the database

    define('DB_USER', 'believe1'); // Your MySQL username

    define('DB_PASSWORD', '******'); // ...and password

    define('DB_HOST', 'localhost'); // 99% chance you won't need to change this value

    define('DB_CHARSET', 'utf8');

    define('DB_COLLATE', '');

    // You can have multiple installations in one database if you give each a unique prefix

    $table_prefix = 'wp_'; // Only numbers, letters, and underscores please!

    // Change this to localize WordPress. A corresponding MO file for the

    // chosen language must be installed to wp-content/languages.

    // For example, install de.mo to wp-content/languages and set WPLANG to 'de'

    // to enable German language support.

    define ('WPLANG', '');

    /* That's all, stop editing! Happy blogging. */

    define('ABSPATH', dirname(__FILE__).'/');

    require_once(ABSPATH.'wp-settings.php');?>

  4. Jeremy Clark
    Moderator
    Posted 7 years ago #

    Its caused by a line break OR spaces after the closing ?> in your wp-config.php
    We can't tell what was in your wp-config file after pasting it here. The best thing to do is to open the file in notepad then put your cursor right after the very last ?> and then hold delete for a few seconds to make sure you get the space deleted.

  5. whooami
    Member
    Posted 7 years ago #

    i didnt ask you whats inside it, i've told you. repasting it here proves absolutely nothing.

    There are linebreaks OR spaces at the end of the file -- you will NOT see them in a paste.

  6. legitptc
    Member
    Posted 7 years ago #

    ok sorry, i managed to fix that problem!!

  7. whooami
    Member
    Posted 7 years ago #

    and now what remains, problem wise. chances are that fixed the cookie problem as well. so whats left?

  8. legitptc
    Member
    Posted 7 years ago #

    oh my gosh thank you so much whooami.

    No more problems...everything is great! you are wonderful thank you.

Topic Closed

This topic has been closed to new replies.

About this Topic