Support » Plugin: Five Star Restaurant Menu - WordPress Ordering Plugin » Small bug in admin “edit price”

  • When we edit in the admin list MENU ITEMS directly under price “edit”, it’s duplicating the prices on update. First you don’t see it but if you reload the page, you will.

    See the 5th line prices are both duplicated https://pasteboard.co/JcTe7Uv.jpg
    It did the same before last update but for the entire prices list… I see now it’s only doing it on the item updated.

    Beside that, the plugin is great. I just regreat there is no option to add dot line between item title and price.
    And the responsive for mobiles doesn’t look so good (prices on the right and 100% need to be added manually in css). Most people are now looking restaurant menus from their phone.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Support jaysupport

    (@jaysupport)

    We fixed the first thing you mentioned last November in version 2.0.5. Since then, no one has correctly explained to us how to recreate the issue, or been able to provide us with any more info than “it doesn’t work.” We’ve already asked several times for detailed steps and any possible information that we can use to make this happen, so we can only repeat this so many times. We’ve also given suggestions about what users might have been doing to cause this, but no one confirmed anything back to us, and, so, I’m not sure what we can do at this point. As you can see from all past threads, we fix any actual issue with the plugin very quickly. If there is a problem, and you can let us know exactly how to recreate it, and we are able to recreate it, I guarantee you we will work on fixing it.

    I just recorded the following screencast, which shows me updating a price, via the Edit Price link, for two separate items – one with a currency symbol and one without. I then click to reload the page. I then do a hard refresh in browser. It works perfectly correctly.

    https://www.etoilewebdesign.com/Screenshots/editprice.mov

    Have you tried experimenting with using different combinations of numbers, characters, etc. to see if it’s a specific character or string of characters that is causing the issue? For example, is it when you use a slash? Is it when you use a specific currency symbol? When you use words? Anything else?

    For any styling issues/conflicts/modifications you wish to make, that should easily be possible by adding some custom CSS. If you have a specific element that you need help with, just let me know, and provide me with the URL, and I’ll have a look and make a corresponding suggestion for CSS you can use.

    I understand. Now, I’ve entered all the items and it’s live, I’m a bit afraid to do it for making a video because it’s not only duplicating the one I change, but other items too.

    I will try reproducing the bug on another testing website and make a video. But I’m in a rush so I need to finish some other works first.

    @jaysupport sorry to say but your statement that you never received feedback other then “it doesn’t work” is far from the truth.

    This issue was originally reported by me here

    I worked with you, gave you a video and answered all your questions. At last, I told you I could even reproduce it in a clean WordPress install and I asked you if you wanted access to that site for you to try out. You never gave an answer.

    In the last few weeks there are 2 more users who replied they have the same issue and you didn’t follow up. I replied with the advice to create their own ticket and now the third person who has the same issue did.

    Anyway, here is a video where I show you two different ways to reproduce it with version 2.1.6

    http://somup.com/cY1YolQucQ

    • This reply was modified 1 month, 2 weeks ago by jpnl.
    Plugin Support jaysupport

    (@jaysupport)

    I’ve seen and read and taken into account everything everyone has posted. None of it has led us to be able to recreate the issue. This is why we continued (both me here in the forums, as well as the email support team for anyone who emailed about the same issue) to ask the same questions over and over pertaining to what exactly we need to do to duplicate your issue. As for the video you just posted, the only difference I can see between that video and the one I previously posted is you’re using commas instead of periods in your numbers. So here’s a video I just made using commas in my numbers. It still works perfectly for me/us. I even threw in some words just to show you that we’ve tried to mimic everything people have told/shown us, but it’s just not doing it for us. And there’s another hard refresh at the end, just to make sure we are doing a good page reload. Now that you’ve seen this latest video, what is different about what I’m doing compared to what you’re doing? How can I do what you’re doing in order to create the issue on my end? You know what the only difference I see is? You have extra filtering boxes beyond the default three that should be there. Could they be messing with our meta information? Can you disable those and try again?

    https://www.etoilewebdesign.com/Screenshots/editprice2.mov

    Hi @jaysupport, I think the issue with reproducibility is that it continues to be reproducible for us even if it is not for you. Since it happens to many of us, I would assume that it is reproducible in general, even if it does not seem to work in your instance(s).

    This suggests me that maybe you have a specific configuration on your side which makes this not happen anymore, but it is still happening to us. Probably if you deploy this in a fresh environment you might be able to reproduce this on your side, or observing the videos that people such as @jpnl have shared.

    @jaysupport the exra filter boxes come from Yoast SEO. I have disabled that plugin and can still reproduce.

    I see another difference between your and my video. You have the options orders and item icons. I assume these are from the pro version which I don’t have. Could that be the reason you can’t reproduce?

    Like @jandradas, I also think the best way for you to try to reproduce is in a clean WordPress install with the default theme and only your plugin without pro license. That’s what I did before to make sure there wasn’t a conflict with other plugins or my theme.

    @jpnl I have the pro version nd I still have the bug. But only when there is something else than numbers.
    @jaysupport For exemple if you put into the price field “small 7” then another item price “large 12”, I think you should be able to reproduce the bug in the listing page. It does it also with “+2” when we add supplement price.
    You need to reload the admin page to see it doubled the prices.

    • This reply was modified 1 month, 1 week ago by Picturgency.
Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.