Support » Plugin: Awesome Support - WordPress HelpDesk & Support Plugin » Slug setting is not working

  • Resolved Kieran

    (@naughtybiscuit)


    Hi,

    I am unable to achieve anything when changing the setting for slug, if I choose ticket ID, random or GUID I still get the ticket title / default behavior of pre 4.0

    Running a clean install of WordPress 4.7.4 and Awesome Support 4.0.1

    Kind regards,

    Kieran.

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author awesomesupport

    (@awesomesupport)

    Hi:

    So the only plugin installed is AS 4.x? I just tested that again here with the GUID option and that worked so just confirming that there are no other plugins installed.

    We’ll try again tomorrow with a clean install of WP to duplicate this.

    In the meantime, just for the heck of it, disable AS and re-enable it then go to the TICKETS->SETTINGS->ADVANCED Tab, choose an option and then hit the save button. After that, try a new ticket to see if that creates the proper slug format for you.

    Kieran

    (@naughtybiscuit)

    It is indeed.

    I tried your steps and nothing changed unfortunately. I am hosting on SiteGround and running PHP 7.1 – I have tried running it under Twenty Seventeen, KLEO and Salient themes just to rule that out too.

    I also have a secondary issue that the media gallery does not work when the plugin is activated.

    Plugin Author awesomesupport

    (@awesomesupport)

    Are there any errors being thrown in the error.log file when the wordpress debug flags are turned on? If so can you attach them here so we can review? Maybe they’ll give us a clue as to what’s happening.

    Thanks.

    Kieran

    (@naughtybiscuit)

    Hey I am getting only the following in my error log

    [17-May-2017 06:48:06 UTC] PHP Warning: mkdir(): No such file or directory in /…/wp-content/plugins/awesome-support/includes/file-uploader/class-file-uploader.php on line 357

    I have since reverted to using version 4.0.0 and I no longer have the media gallery issue.

    Further testing has revealed that when a user creates a ticket via the front-end the slug issue is not present (AKA: it generates a ticket with a random number, as expected). Most of my tickets are generated via the back-end, any tickets generated in the back-end have the standard slug and not the randomly generated number that I had hoped to use.

    I consider this ticket resolved as it isn’t really a bug, but it would be nice to see the slug work as expected via the back-end too. Thanks for your assistance 🙂

    Plugin Author awesomesupport

    (@awesomesupport)

    Hi:

    Thanks for the troubleshooting on this one. We’ll duplicate and fix in a point release.

    Regarding that upload error – can you open a new thread on here for that so we can address and troubleshoot it separately? I’d like to keep this thread open for just the slug issue so we can report back on it once its fixed.

    Thanks so much!

    Plugin Author awesomesupport

    (@awesomesupport)

    If you’d like to apply a patch for the slug issue just open the file awesome-support/includes/admin/functions-post.php and go to line 153. Immediately below that line just put this:

    wpas_set_ticket_slug( $post_id );

    It should look something like this: https://www.screencast.com/t/3rseCkOX

    We’ll have this patch in the next point release.

    Thanks for the report!

    PS: There are two files with name functions-post.php in different folders. The one you want is in the admin folder.

    Kieran

    (@naughtybiscuit)

    Hey, thanks for your response – I tried your solution, it works and it doesn’t. Let me guide you through what I get.

    – Back-end > tickets > add new
    – Title, body, user, product set
    – Save, page does not load immediately
    – New tab > tickets > ticket shows with the title that I set. The slug says it is /ticket/863268646/ I click view and get a 404
    – Eventually the page for adding the new ticket times out and shows Error 504
    – I refresh the tickets page and now the slug changes for the ticket to /ticket/542755416/
    – When I open the ticket I get the correct page, the ticket I attempted to create and got an error with now displays as expected.

    Very confusing :/

    In my error logs I get the following

    [18-May-2017 01:43:22 UTC] PHP Notice: Undefined index: original_post_status in /…/wp-content/plugins/awesome-support/includes/admin/functions-post.php on line 85

    Kieran.

    Plugin Author awesomesupport

    (@awesomesupport)

    Hi:

    Thanks for the details. I just need some clarification – when you say you “Save”, are you clicking the OPEN TICKET button or are you saving the ticket some other way? Right now when I click the OPEN TICKET button the page refreshes almost immediately and the new slug is shown under the title.

    Thanks.

    Kieran

    (@naughtybiscuit)

    Sorry! Yes, I meant Open Ticket.

    Kieran

    (@naughtybiscuit)

    Running 4.0.2 update and I can confirm that the fix is working.

    All tickets are created with a random number from the back-end / front-end and do not cause the page to hang or fail.

    Thanks for your time,

    Kieran.

    Plugin Author awesomesupport

    (@awesomesupport)

    Hi:

    You beat me to it. I was going to ask if it resolved your issue. Glad it did.

    Thanks!

    Kieran

    (@naughtybiscuit)

    Hey,

    It appears to be back with a vengeance. When creating a ticket through the back-end I get the slow to load page and it generates a normal tickets slug instead of the random number. It also sends out exactly 68 emails every time one is created.

    Plugin Author awesomesupport

    (@awesomesupport)

    68 emails? Not sure what’s going on there. Are you using the email support module? if so it probably means you’ve created some sort of loop where your auto-confirmations are generating replies back to your support mailbox.

    Kieran

    (@naughtybiscuit)

    Hi,

    This resolved automatically with an update, I have marked it as such.

    Sorry for not getting back sooner, I got side tracked and forgot.

    Kieran.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Slug setting is not working’ is closed to new replies.