Support » Plugin: WPGlobus - Multilingual Everything! » Slug not working

  • Resolved erik404

    (@erik404)


    Hi,

    The language URL slug does not work on my live environment but does work on my development environment.

    When I click the language I get the correct URL’s like localhost/ru, or localhost/ru/work

    On live these links (which I fetch via WPGlobus_Utils::localize_current_url( $lang )) result in just the domain of my website.

    I worked before on live though but I can’t pinpoint what the exact cause could be.

    I think it has something to do with me moving the database to the live environment and change the URL’s in the tables from localhost to my domain name.

    Also I upgraded WP and the WPGlobus plugin on both live and local, live does not work, local does.

    I tried removing the WPGlobus plugin, installing it again. No luck.
    I disabled every other plugin, no luck.
    I tried different themes, no luck.

    Is there some cache I could flush or a table which needs to be emptied to solve this issue? I strongly feel that there is some corrupt innformation.

Viewing 2 replies - 1 through 2 (of 2 total)
  • de website by the way is reachable via http://www.codebeard.nl:8080

    Plugin Contributor Alex Gor

    (@alexgff)

    from here
    DEVELOPING ON LOCALHOST OR CUSTOM PORTS
    WPGlobus may not work correctly on development servers having URLs like //localhost/mysite or on custom ports like //myserver.dev:3000. Please use a proper domain name (a fake one from /etc/hosts is OK), and port 80.

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.