Support » Plugin: WP Hide & Security Enhancer » Slows down website — dramatically

  • Resolved JJNW

    (@jjnw)


    Hey, man. Great plugin. BUT… I have 74 plugins — response and load time under 2 seconds. I add your plugin — even without configuration, just turning the sucker on — 12 seconds to load a page –> 12 seconds. Any suggestions… pretty please?

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author tdgu

    (@tdgu)

    It sound like a conflict with another code.
    Can you also check the server error log? nd try to disable other plugins one by one to find the once which interfere. Also keep the Rewrite – URL Slash option off.

    Great morning! Okay, I will start that process and update with results by this Sunday. Thanks for the suggestion. Note: I am using Kleo-Child (Kleo) theme, in case you already know of a conflict there?

    Well, I’ve been trying for long hours all day. No luck what-so-ever. I shut off plugins, one by one, in groups, removed custom code, custom js, sections of the Kleo theme, Kleo Child theme, htaccess, etc. No luck. Very disappointed I couldn’t figure it out. Any other suggestion? Any? 🙁 And I did try to your suggestions.

    • This reply was modified 2 years, 3 months ago by JJNW.

    Oh, I didn’t try error log… give me a few. Update soon.

    • This reply was modified 2 years, 3 months ago by JJNW.

    Nope 🙁 No log errors or screen notices using error_reporting(E_ALL); ini_set('display_errors', 1); and using define('WP_DEBUG', false); No Apache errors. No PHP errors in logs. No WordPress warnings. Just mass slow when I only activate your plugin… and configuring doesn’t make any difference. Just slow for activating your plugin — which I love and it works, but too darn slow (goes from 2 seconds load, to 6 to 8 seconds, upwards of 12 seconds to load 🙁 Any suggestions? Any? Publaseetoe… any? an…y?

    • This reply was modified 2 years, 3 months ago by JJNW.
    Plugin Author tdgu

    (@tdgu)

    That’s weird.
    Can you send what phpinfo() reports? Use the https://pastebin.com/ or something similar to send the report.

    Cool! I have to go to the man, I mean el workeetoe in the lab, so please give me until tonight to post. And thanks for sharing that pastebin link! Chat very soon! Note: Update: I have your plugin working just fine with another website on my localhost — yet it has a different theme, and only 8 plugins versus 74 plugins (but I don’t know if it’s a plugin issue since I tried deactivation with no results)…. . I just tried one more thing as I am typing, and still slow = I deactivated ALL 74 plugins + yours = website screams fast, then I just ONLY activated your plugin, and website response time is that equal to the 74 plugins all activated…. 74 plugins activated takes 2 seconds to load website, yet, just your plugin takes 2 seconds to load website. If I use all 74 plugins + yours = anywhere from 7 to 12 seconds per page load. Okay, I will update tonight with php info. Thanks for your help!!! 🙂

    Okay, before we get into php info, note, I already have the plugin working on another website on this localhost server and it’s working great. Now, I did buy Hide My WP –> YOURS is way easier and better, but I literally got the same results as yours –> 7 to 12 seconds to load a page. So then I removed that plugin (Hide My WP too) and I tried WP Super Minify –> Same results –> load page 7 to 12 seconds. If I leave the website as is, at 74 plugins –> screaming fast, like < 2 second page load. I even used P3 (yes it worked flawlessly on my 4.7.5 WordPress) and even used Query Monitor –> but no dice Chico = it didn’t find anything obtuse or odd. I wonder what it is.

    So, since it slows down with your plugin, Hide My WP, and some other random plugins like WP Super Minify and BWP Minify, I am confident it’s NOT your plugin. Sorry for bothering and thanks for the help and awesome plugin. I will still have to figure out why its slowing down, but I don’t believe its your plugin anymore. Again, thanks for helping all the same, and of course providing an awesome FREE plugin. And those that want to know, Hide My WP costs about $20, and isn’t as easy or intuitive as this plugin. Just saying 😉

    • This reply was modified 2 years, 3 months ago by JJNW.

    UPDATE = The issue is on localhost, WAMP, else XAMPP, else AMPPS settings…or Windows 7 settings –> complicated nutty I couldn’t figure out.

    But on dedicated server live site (using Centos 6 with PHP 5.5.38 on WordPress 4.7.5) no problems! It works perfect 🙂

    Thanks for the plugin and the wild chase!

    • This reply was modified 2 years, 3 months ago by JJNW.

    Update: to really, really make this website scream in speed, I strongly encourage you to implement Opcache and Memcache.

    Great, GREAT plugin.

    Thank you!

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Slows down website — dramatically’ is closed to new replies.