Support » Plugin: SparkPost » Slows down site

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Contributor rajuru

    (@rajuru)

    @shreyans94
    I’ve a few questions to understand this and to find a solution.

    – How did you determine that?
    – What mailer are you using (SMTP/HTTP)?
    – Did you try alternate method?

    Thanks

    Ok so I made a quick video to demonstrate the issue.

    Let me know if there is a fix for this.

    https://www.useloom.com/share/4f826b7ec8864718984878bce9b26987

    Plugin Contributor rajuru

    (@rajuru)

    That’s so cool. Thanks for making it. Here are a few suggestions:

    – Try sending a test mail using the plugin and see if it still taking long.
    – Try using HTTP API mailer (you’ll need to add appropriate permissions to your API Key though).
    – Also I see you’re using port 2525. Try default SMTP port 587 if that’s unblocked in your host.

    Please get back to us if any of this doesn’t help. We’ll investigate if there is something at our end as our status report doesn’t show any issues that can cause slowness.

    Thanks

    shreyans94

    (@shreyans94)

    I tried HTTP API and it reduced load time by 6 seconds which is massive, however even HTTP API adds 2.5 sec time vs disabling the plugin altogether, and 2.5 sec is also A LOT.

    Lag is both with 2525 and 587

    • This reply was modified 2 years ago by shreyans94.
    Plugin Contributor rajuru

    (@rajuru)

    That’s great to hear.

    Check with your host if it’s causing the slowness at origination level.

    Regardless, HTTP API will be faster (at normal circumstances) and I recommend you to use it.

    • This reply was modified 2 years ago by rajuru.
    shreyans94

    (@shreyans94)

    But even HTTP API adds 2.5 sec time vs disabling the plugin altogether, and 2.5 sec is also A LOT.

    I am using VPS on DO it is not the issue as the thank you page loads in <2 sec when sparkpost is deactive, but loads in 4-5 sec sparkpost on HTTP API, loads in 10-11 sec sparkpost on 2525 or 587

    Plugin Contributor rajuru

    (@rajuru)

    At this point I will suggest you do some profiling to find out which step exactly taking up your time.

    shreyans94

    (@shreyans94)

    What do you mean by do some profiling sorry I dont get it?

    Also i already know at which step it is slowing down which is the load time between checkout and thankyou page.

    Default load time with plugin off 2 sec.

    HTTP API slows 2.5 sec so 2+2.5= 4.5 sec load time

    2525 or 587 setting lags it by 6 sec so 2+6 = 8 sec load time

    What else do I do / say?

    • This reply was modified 2 years ago by shreyans94.
    shreyans94

    (@shreyans94)

    Waiting for a reply

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Slows down site’ is closed to new replies.