Support » Fixing WordPress » Slowly 'disappearing' categories in 3.1.1

  • Hello!

    We are having a very unusual issue of slowly disappearing categories. The order of events is sort of in this order.

    1. Everything is fine and dandy after we updated to 3.1.1.

    2. In the list view of posts, under the categories column, we only see ‘uncategorized’.
    In edit and quick edit, we can see that they ARE categorized, and we can see there are categories in the filter tool. On the site itself, clicking the category buttons give us ‘there are no posts here (yet)’ or similar.

    3. Everything becomes totally uncategorized (even in edit views) and the filter tool shows no categories. However, on the dashboard, there are supposedly 9 categories. On the category admin page, there is nothing listed.

    Deactivating all plugins has not worked. Reinstalling wordpress has not worked.

    The wp export file has no categories on it, we uploaded it to another blog.

    Installing the wordpress application on a fresh subdomain (new database, new user, etc) eventually has the same issue after updating to 3.1.1, when the wp export file is loaded and new categories are assigned. The new categories eventually ‘disappear’.

    Recreating the entire site (new database, new user, etc) on the same domain has the same result.

    Note: In the dashboard, we can always see there are as many categories as we have created. If we try to create a category with the slug of one that we created before, that is denied even though there are no listed categories.

    Obviously something is being screwed up in the database or WP’s code, but we don’t know exactly how to fix it other than reinstall everything and NOT update wordpress.

Viewing 3 replies - 1 through 3 (of 3 total)
  • And now the problem has magically resolved itself after a couple hours of doing nothing.

    There was definitely an issue however, seen using multiple computers, so if anybody has some advice on avoiding that in the future, that would be much appreciated!

    Thanks! 😀

    I have exactly just now the same problem as you describe.
    I have WordPress 3.1.2

    So I wait a few hours and everything is fixed again ???

    I have 3 blogs in one website, so I did checked these too.
    Also the other blogs has the same problem.

    So I called my hosting company and they found out that MySql had troubles to write temporally files in a specific directory.
    They created the directories again after deleting.
    Now everything is okay again.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Slowly 'disappearing' categories in 3.1.1’ is closed to new replies.