• Resolved Education Guide Administrator

    (@educationguideonline)


    Hi, after activating Ninja Form on my site it is slowing down my site by more than 2 secs. It is only 2 secs, but it is too big for my site. Repair this or tell me any method to disable the action on other pages rather only on the ninja form page.

    My GTMetrix Report—
    POST admin-ajax.php (time taken 2.11 s)

    **Post:
    action=nf_ajax_get_new_nonce

    **Response:
    {“data”:{“new_nonce”:”a379b47a38″,”nonce_ts”:1541699680},”errors”:[],”debug”:[]}

    The page I need help with: [log in to see the link]

Viewing 1 replies (of 1 total)
  • Plugin Author krmoorhouse

    (@krmoorhouse)

    Hey @educationguideonline ,

    This functionality is required for form submission. So, there isn’t a way to disable it. The code needs to run on any page where a Ninja Form exists. As it appears you are including an email subscription form in the footer of your WordPress site, this code will execute on every page where that footer exists.

    That said, while the call appears long at first glance, the only thing the AJAX call delays is the display of the Ninja Form. Any other content on the page is not blocked by the call.

    Looking through the network waterfall for your page, I can see that this specific call isn’t even made until 2.3 seconds into page load. So, if your issue is the load time of the overall page, I would suggest looking further up the waterfall for what might be slowing it down.

    From a glance, it looks like reCaptcha is taking quite some time to load, but the main load time is on the site itself, which indicates your theme is probably where the bulk of your load time is coming from.

Viewing 1 replies (of 1 total)
  • The topic ‘Slowing down my site’ is closed to new replies.