WordPress.org

Forums

The Support Forums will be in read-only mode for a scheduled maintenance window on 01 September 2016 14:00 UTC - 20:00 UTC. More information.

Auto Affiliate Links
Slowed down my site to a crawl (15 posts)

  1. mfalkvidd
    Member
    Posted 3 years ago #

    Not sure what I did wrong, but installing this page and adding just one affiliate link took page load times from 700ms to >10,000 ms. De-activating the plugin made the site fast again.

  2. Lucian Apostol
    Member
    Plugin Author

    Posted 2 years ago #

    Hello.

    The excesive load time you experienced was on the front-end ? e.g. when the site was displayed to visitors ? or in your wp-admin area ?

    Can you give me more info about this problem so I can find a solution ?

  3. mfalkvidd
    Member
    Posted 2 years ago #

    It was on the public pages seen by visitors that are not logged in.

  4. Lucian Apostol
    Member
    Plugin Author

    Posted 2 years ago #

    Would you like to test the current version of the plugin to see if the problem persist ?

  5. mfalkvidd
    Member
    Posted 2 years ago #

    Sure. Not sure when, but I should be able to do it during the weekend at least. I'll report back when I have the results.

  6. mfalkvidd
    Member
    Posted 2 years ago #

    Yes, the problem still persists. If the plugin is activated, response times from my public blog pages are >10 seconds. With the plugin inactivated, response times are ~1 second.

  7. Lucian Apostol
    Member
    Plugin Author

    Posted 2 years ago #

    I have made a new release yesterday, but I am not sure if it will fix your pboelem. Can you give me more details about your configuration ?

    - php version
    - wordpress version
    - how many posts do you have on your blog

  8. mfalkvidd
    Member
    Posted 2 years ago #

    PHP 5.5.0
    Wordpress 3.6.1
    51 blog posts

  9. Lucian Apostol
    Member
    Plugin Author

    Posted 2 years ago #

    I have tested on an environment specially created similar to yours and it worked for me. How many affiliate links do you have in the plugin admin area ?

    Please disable the plugin and uninstall it from your blog so any data to be removed, and then install it again. Please let me know if it is still slowing down your website ?

    What hosting provider do you work with ?

  10. mfalkvidd
    Member
    Posted 2 years ago #

    I added only one affiliate link.
    I have my own VPS on Linode.
    Will try to set up a new clean blog with only your plugin and see if I have the same problem. I'll report back when I have some news, but it might take a while.

  11. Lucian Apostol
    Member
    Plugin Author

    Posted 2 years ago #

    I've made some changes to the plugin and improved loading page time by more than 10 times. Please use the latest version when you do your checks.

  12. mfalkvidd
    Member
    Posted 2 years ago #

    Great, thanks!

  13. Lucian Apostol
    Member
    Plugin Author

    Posted 2 years ago #

    Was the last update fixed the loading problem for you ?

  14. mfalkvidd
    Member
    Posted 2 years ago #

    Yes, I am unable to see any slowdown now. Great work!

  15. Lucian Apostol
    Member
    Plugin Author

    Posted 2 years ago #

    Thank you for your help in figuring out this issue.

    Best Regards.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.