Support » Theme: CoverNews » Slow Website Speed : Fonts file causing increase page load time

  • Today i ran a analysis of my website: [ redundant link removed ] on

    One of the thing which caught my attention was Fonts file whose size are quite small(in few kbs) were taking a long time to load.

    When cross checking with PageSpeed Insights, it showed i can save aprorox 200m/s on each font file.
    Font files are :

    Can anybody suggest some tips to improve my loading time (current:4.7s) and PageSpeed Score(current:61) by making these fonts files load faster?

    • This topic was modified 6 months, 3 weeks ago by aanuragshukla.
    • This topic was modified 6 months, 3 weeks ago by Jan Dembowski. Reason: Moved to Fixing WordPress, this is not an Everything else WordPress topic

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Moderator t-p


    I recommend asking your theme’s author for any suggestions.

    If you like, I can move to the dedicated support of your covernews theme.

    • This reply was modified 6 months, 3 weeks ago by t-p.
    Thread Starter aanuragshukla


    Hi @t-p

    yes, please move to the dedicated support. it would be a great help.
    Thanks in advance

    Moderator t-p


    What theme are you using?
    Exactly where did you download it from?

    Thread Starter aanuragshukla


    Hi @t-p
    My theme: CoverNews Version: 1.4.0 by AF themes

    I downloaded it from within the wordpress theme section.

    Thanks for using our theme.
    Please follow this post to know how to speedup the website.

    That is the fonts we needed for the theme. So, you can optimize with the help of the plugins. Please follow the steps.

    Thank you

    I was facing the same error. It can be solved by using the Asset Cleaner Plugin. Open settings, click on local fonts and preload these specified fonts causing your web slower.

    Watch Video Here

    Best of Luck!

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.